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1. Preface

1.1. About this Tutorial
This tutorial consists of four parts: Beginner, Intermediate, Advanced, and More Advanced. It is
designed to help you learn how to use CADdoctor SX step by step. Each content will be
explained in detail.

2, Beginner

This level explains the basic operation for translating data in CADdoctor SX. If the quality of
data are not so bad, translation can be done just with the knowledge of Beginner level.

3, Intermediate

This level explains how to correct errors by using Interactive Healing. Most of the data can
be translated properly with the knowledge of Intermediate level.

4, Advanced / 5, More Advanced

For errors which could not be corrected with the knowledge of Intermediate level are
explained in the form of case studies. Please refer to these case studies whenever necessary.

Furthermore, the functions described in this tutorial are just a part of CADdoctor SX. Please
refer to the help for other functions.

About Help

For help, select [Help] > [Help Index] from CADdoctor SX menu. The help provides details
about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark appears next to the cursor so either double-click the menu or just click the
icon.
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

Example:
For example, the "Fit" function is described as [View] > [Fit] (  ).

1.3. About Explanatory Notes
Explanatory notes are categorized as follows:

 Contains important information. Be sure to check and set this item.

 Warnings are listed. Be sure to check these items.

 This information is useful when using the product.

 Contains information that can be used for reference.

1.4. About Sample Data
The sample data to be used is located in the folder " \document\tutorial_models\standard" inside
the folder where CADdoctor SX is installed.

In this tutorial, the folder containing sample data is referred to as <tutorial>.

1.5. About Images
The images in this document may include slight differences from the ones actually displayed on
your CADdoctor SX depending on your specific computer hardware and the CADdoctor SX
version.
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2. Beginner
This section will explain the basic operation for translating data in CADdoctor SX.
If the quality of the data are not so bad, translation can be done just with the knowledge of
Beginner level.

Firstly, this chapter will explain about "Basic Operation" and "File Management." Then to 2.3,
“General Data Translation” which is about the basic translation method, and 2.4, “Geometry
Verification Mode” which compares before and after modification of geometries.

2.1. Basic Operation
This section will explain the basic operation of CADdoctor SX.

2.1.1. User Interface

① Menu bar Displays various commands.

② Toolbar Displays frequently used icons from the menu bar.

③ Main panel Used mainly for basic operations. Run [Check] and [Auto Heal] for
check items displayed in the list.

④ Navigation panel Displays the most suitable tool to modify the check item. Also,
when switching to [Fit], the fitting tools will be displayed.

⑤ Status bar Displays information such as the current status and a guide to the
next operation.

⑥ "3D View" window Displays the imported model.
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■ Navigation / Guide

Advises the best way to modify the error items.

• Navigation

• Guide (Repair Tool / Auxiliary Tool)

The operation procedure is as follows.

1. In [Main (Work)] panel, select the error item from the category list.

2. The best modification method is displayed on Navigation panel. Press and use the
appropriate one.

◦ Repair Tool: Effective for error modification.

◦ Auxiliary Tool: Creates reference lines, etc. needed for repair tools.

◦ Guide: Explains in detail Repair Tool / Auxiliary Tool on the Navigation panel.
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2.1.2. View Operation

■ Mouse Operation

This section explains how to use the mouse on "3D View" window.

Command Description Mouse / Keyboard Shortcut

 Pan Move the model parallel. Right mouse button + drag

 Rotate 3D Rotate the model in 3D
according to the mouse
movement.

Left mouse button + drag

 Rotate 2D X Rotate around the horizontal
axis of "3D View" window.

(Left and right of the screen)
Left mouse button + drag

 Rotate 2D Y Rotate around the vertical axis of
"3D View" window.

(At the bottom of the screen)
Left mouse button + drag

 Rotate 2D Z Rotate around the depth axis of
"3D View" window.

(At the top of the screen)
Left mouse button + drag

 Fit Automatically adjust all
elements to fit in "3D View"
window.

Ctrl + F

 Zoom The view is zoomed in and out.
(When zoomed in, the vertical
height doesn’t change, but
moves in the depth direction
and the opposite direction.)

• Mouse scroll wheel
• Middle mouse button + drag
• Both mouse button + drag

 Zoom Area Zoom into the area enclosed by
a rectangle. None

 Fix Rotation
Center

Set the specified point as the
center of 3D rotation. Ctrl + Q

 Fix Rotation
Axis

Specify the rotation axis when
rotating the plane. None


Please note that the rotation method in "3D View" window will change
depending on where you drag from.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 5 | 156



• Drag at the top of "3D View" window: Rotate 2D Z ( )

• Drag at the bottom of "3D View" window: Rotate 2D Y ( )

• Drag at the left of "3D View" window: Rotate 2D X ( )

• Drag at the right of "3D View" window: Rotate 2D X ( )

• Drag at the center of "3D View" window: Rotate 3D ( )

■ Change View

This section will explain how to change the view using the toolbar icons.

Command Description

Snap to Axis Change the current view to the closest basic axis view, then fit
the view.

XY Change the viewing angle toward XY

YX Change the viewing angle toward YX

YZ Change the viewing angle toward YZ

ZY Change the viewing angle toward ZY

ZX Change the viewing angle toward ZX
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Command Description

XZ Change the viewing angle toward XZ

XYZ Change the viewing angle toward XYZ

YXZ Change the viewing angle toward YXZ

Command Description

Rotate 2D X (90 degree) Rotate 90 degrees vertically

Rotate 2D X (180 degree) Rotate 180 degrees vertically

Rotate 2D X (270 degree) Rotate 270 degrees vertically

Command Description

Rotate 2D Y (90 degree) Rotate 90 degrees horizontally

Rotate 2D Y (180 degree) Rotate 180 degrees horizontally

Rotate 2D Y (270 degree) Rotate 270 degrees horizontally

Command Description

Rotate 2D Z (90 degree) 90 degrees plane rotation

Rotate 2D Z (180 degree) 180 degrees plane rotation

Rotate 2D Z (270 degree) 270 degrees plane rotation

■ View Mode

This section will explain how to change the display type using the icons on the toolbar.
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Command Description

Wireframe Display elements in wireframe mode

Shading + Wireframe Display elements in shading and wireframe mode

Shading Display elements in shading mode

Semi Transparent Display elements in semi-transparent mode
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Saving View Direction

With CADdoctor SX View Configuration function, it is possible to register any view
direction and display it again later. View information is held by CADdoctor SX, not by
each model. Therefore, the registered view direction can be shared between different
models.

■ How to Save View Direction

1. Display the model by the view direction that you want to save.

2. Select [View] > [Change View] > [View Config] from the menu.

3. "View Management" dialog will appear. A list of previously saved view names is
displayed. Click [Create] to save new view.

4. "View" dialog will appear. Enter the name to register, then click [OK]. The newly
created view direction is registered.

■ Redisplay with the Saved View Direction

1. Display "View Management" dialog in the same way as you did in "Saving View
Direction".

2. Select the preferred view to display from the list and click [Apply]. Selected view
information is reflected on the screen.

If you save the errors in CADdoctor SX with this function , the viewpoints can easily be
redisplayed for checking after modification.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 9 | 156



When "3D View" window is coarse

Zooming in and out of "3D View" window may result in a coarse appearance of the model.
In such a case, select [View] > [Regen] from the menu or click [Regen] ( ) on the toolbar.
"3D View" window will be updated.

2.2. File Management

2.2.1. Open Files

Open .drfx_sx file that contains the working state of CADdoctor SX.

1. Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar.

2. "Open" dialog will appear. Specify .drfx_sx file and click [Open].


The sample data used in the tutorial is located in "document" >
"tutorial_models" folder inside the folder where CADdoctor SX is installed.
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2.2.2. Save Files

With CADdoctor SX, the current working state can be saved as a .drfx_sx file.

1. Select [File] > [Save As] from the menu.

2. "Save As" dialog will appear. Specify the location and file name to save, and then click
[Save].


When editing an existing .drfx_sx file, click [Save] ( ) to overwrite the
currently opened .drfx_sx file.

About the sample data in the tutorial

The sample data in the tutorial are "read-only" and cannot be saved.

To save the sample data you are editing, select [Save As] to save it under a different file
name.
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2.3. General Data Translation
When translating data, errors caused by the differences in tolerance and data structure
between the source and target CAD systems need to be corrected.

With CADdoctor SX, you can correct these errors and translate the data with the following
operation flow.

1. Import file from source CAD system

2. Check and detect errors that may cause problem during translation

3. Correct the detected errors

◦ Auto Stitching

◦ Auto Healing

◦ Interactive Healing

4. Export file to target CAD system

Beginner level follows the above operation flow to translate the sample data.

2.3.1. Mode

CADdoctor SX has multiple modes that can be switched depending on your purpose. In this case,
use "Translation" mode which is most suitable for data translation.

1. Click "Translation" from the drop-down list at the upper left of [Main (Work)] panel.


Please note that each mode requires an optional license when switching to,
for example, Simplification mode.



You can also switch the mode from the file menu.
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2.3.2. Import

Import the sample model (SAMPLE1.igs) into CADdoctor SX.

1. Select [File] > [Import] from the menu or click [Import] ( ) on the toolbar.

2. "Open" dialog will appear. Change the type of file to "IGES (*.iges, *.igs)" and click [Option].

3. "Option" dialog will appear. In "Stitch (Stitch)", enable "0: Don’t stitch." and click [OK].


Please note that "Stitch" is disabled intentionally at this point because it is
necessary in the operation explanation that follows. Normally, you do not
need to disable "Stitch".


In "Open" dialog, click [Option]. Set input option in the format specified in
"Files of type".


Please note that the type of files you can import depends on the licenses
you have.
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4. "Open" dialog will appear. Specify SAMPLE1.igs file from the <tutorial> folder and click
[Open]. Specified file is imported and displayed on "3D View" window.

2.3.3. PDQ

This function checks where the errors exist in the imported data.

1. Specify the output target in "Out".

In [Main (Work)] panel, specify the output target in "Out". In this case, specify "CATIA V4".



With CADdoctor SX, it is recommended that you specify the target CAD
system at the time of import. Main options are automatically set for the
source / target CAD system at the time of import. Target CAD system can be
changed before Auto Heal.

2. Detect PDQ errors of the input sample model.

Click [Check] ( ) in [Main (Work)] panel.
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The PDQ check result (number of errors of the corresponding check criterion, impact level
of the corresponding check criterion, etc.) will be shown in Category List upon the
completion of PDQ check.

3. Analyze the detected errors one by one.

In [Main (Work)] panel, select "Gap: In loop" in the category list.


Please refer to A.1, “Error Items” in the Appendix for details about PDQ
check criteria.

The errors are highlighted in red on "3D View" window.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 15 | 156




Switch to Wireframe mode for better visibility. Please refer to "View
Operation" > "View Mode" for the details about the view modes.

4. Analyze the detected errors one by one.

Click [Zoom current target] ( ) in [Main (Work)] panel.

"3D View" window will fit to the result area which is set to Current.



◦ Please refer to 2.1.2, “View Operation” for the details about the view
operation in "3D View" window.

◦ Set the rotation center with [Fix Rotation Center] ( ) to better control
the view operation.

Click [Fix Rotation Center] ( ) from the toolbar, and click anywhere
on the model to set the rotation center at the clicked location.
Alternatively, right-click on "3D View" window, and specify from the
context menu.

Click [Deactivate Rotation Setting] ( ) to release the rotation center.
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5. Select "Gap: In loop" in Category List in [Main (Work)] panel, and switch to Contents List
from the pull-down list.

Contents List will show the list of detected "Gap: In loop" errors with numerical details.

6. Click [Next] ( ) in [Main (Work)] panel.

The next error area will be set to Current.
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 Click [Previous] ( ) to set the previous error area to Current.

Switch the list in [Main (Work)] panel to Category List.

7. Click [Show Surrounding] ( ) in [Main (Work)] panel.

Only the elements related to the error are shown in "3D View" window. This function is
useful when there are numerous elements and it is difficult to see the errors.

 Click [Show Surrounding] ( ) again to reset to show all.

8. Change the view mode of "3D View" window from [Wireframe] ( ) to
[Shading+Wireframe] ( ).
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2.3.4. Auto Stitch

The sample model for this section contains the areas which do not have the adjacency relation
(topology) with neighboring faces, which are detected as "Missing face". This section explains
the procedure to stitch faces to construct the topology relation between them.

1. Click [Auto Stitch] ( ) in [Main (Work)] panel, .

2. "Auto Stitch" dialog will appear. Because the default value will be used in this case, click
[Try].



Please note that the tolerance described in IGES file will be displayed as the
initial value in "Tolerance". For this sample model (SAMPLE1.igs), 0.1 mm
will be displayed.

If the tolerance is not described in the model, the specified "Point
coincident" value in "Check Options" dialog, which can be called from
[Check] > [Options], will be displayed.

Tolerances specified here is used only for Auto Stitch. It will not affect other
tolerances during modification or check.
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3. The number of free edges is updated. In "Auto Stitch" dialog, confirm that the number of free
edges is "0", then click [Fix].



If free edges still remain after clicking [Fix], loosen the tolerance and try
again. However, note that if the tolerance is loosened too much, an error
such as "Gap: Edge and base surface" may occur.

For topological reasons, there are models whose unused edge does not
become "0". If so, check the location of the free edge and determine
whether you need to retry.

Please refer to 4.1, “Modifying Free Edge” for details about the free edges.

The faces will have the topology relation with adjacent faces, and the PDQ check result in
[Main (Work)] panel will be updated.

Flip Face

Orientation of the faces are automatically consistent after stitching; however, in some
cases, the front and back of the faces are reversed.

If the face is in gray, as shown in the lower left figure, the direction of the face is correct
and no modification is necessary. If the face is in khaki, as shown in the lower right
figure, the face is reversed.
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In such a case, select [Modify] > [Repair Solid] > [Flip face] from the menu or click [Flip
face] ( ) on the toolbar to correct the direction of the faces.

2.3.5. Auto Healing

This function can be used to automatically heal errors.

1. In [Main (Work)] panel, press [Auto Heal] ( ).

2. A confirmation dialog will appear. Confirm that the target CAD system is set properly, then
click [OK].


Set the target CAD system at "Out" pull-down list in [Main (Work)] panel
when not set properly.

Automatic geometry healing will be conducted, and some PDQ errors will be repaired
automatically.
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
Please note that the icon color of [Auto Heal] will change from "before"
( ) to "after" ( ).



Depending on the source and target CAD systems, automatic healing may
modify all errors. This is due to the difference in options, etc.

If all errors have been modified, then skip to 2.3.7, “Export”.

Options for Auto Heal

There are two options for Auto-Heal, "Powerful Healing" and "Minimal Healing".

• With Powerful Healing, the usual powerful healing is applied.

• With Minimal Healing, which can heal faster than Powerful Healing, the healing items
are limited to ones that are required to keep the solid model.

Select [Modify] > [Options] from the menu. "Modification Settings" dialog will appear.
Switch the setting in [Auto-Heal] page.

2.3.6. Interactive Healing

When errors still remain after automatic healing, perform interactive healing to modify the
errors.
In this case, the serious level error "Gap: Edge and base surface" will be modified.
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
Please ensure to repair all Serious and Critical level errors, otherwise they may
cause missing faces, etc. in data translation.



In some cases, errors with a severity of "Minor" may remain, which is a
warning level error. You do not have to modify.

Please refer to A.1, “Error Items” in the Appendix for details about error items.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. On "3D
View" window, the position of the error "Gap: Edge and base surface" is highlighted in red.

Also, Repair icons will appear on Navigation panel. These repair icons can be used to modify
the error "Gap: Edge and base surface".


Repair icons are listed from the left side in the order of highest frequency
of use.

2. In [Main (Work)] panel, press [Zoom current target] ( ).
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On "3D View" window, the current target error is zoomed up.

3. Press [Fit Face to Loops] ( ) located at the farthest left of Repair Tool on Navigation panel.

A new surface is calculated, and the geometry of the surface is displayed and highlighted in
light blue on "3D View" window.

4. A confirmation dialog will appear. Click [OK].

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 24 | 156



The error is modified, and the category list is updated.

5. In [Main (Work)] panel, press [Zoom current target] ( ).

On "3D View" window, the current target error is zoomed up.

6. Press [Fit Face to Loops] ( ) located at the farthest left of Repair Tool on Navigation panel.

A new surface is calculated, and the geometry of the surface is displayed and highlighted in
light blue on "3D View" window.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 25 | 156



7. A confirmation dialog will appear. Click [OK].

The error is modified, and the category list is updated. In [Main (Work)] panel, all errors are
now "0" in the category list.


Please refer to Intermediate: 3.1, “Interactive Healing” for details about
modification functions.

2.3.7. Export

In this section, the sample model (SAMPLE1.igs) will be output in CATIA V4 file format.

1. Select [File] > [Export] from the menu or click [Export] ( ) on the toolbar.

2. "Save As" dialog will appear. Specify "CATIA V4 (*.model)" as the type of file. Enter the file
name and location to save the file, then click [Save].
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
In "Save As" dialog, click [Option] to set the output options for the format
specified in "Save as type".


Please note that the type of file that can be exported depends on the target
CAD system selected at the time of import and the license you have.

Check the result

The translation result will be shown in CADdoctor SX when exporting to either of the
following formats.

• CATIA V4

• CATIA V5 (Standalone)

• Parasolid

If the data cannot be translated into solid, the [Results] tab becomes active, and a list of
translation errors will appear. (See below figure)

In such a case, confirm the areas around the translation errors on "3D View" window, and
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repeat interactive healing on the errors. In addition, the failed errors might only be
identified on a per volume basis.

Nothing will appear in the list of translation errors if you were able to translate into a
solid. The sample model used in this case also does not show any errors in the list;
therefore, you can confirm that it was translated into a solid.

 Please refer to the help for more details about Results tab.

Translating Large Files

When translating a large file, set the "Reduce Memory Mode". When this mode is set, a
part of the information on memory is saved to a file, so memory usage can be suppressed.

■ How to Set Up

1. Select [File] > [System Preference] from the menu.

2. "System Preference" dialog will appear. In [Miscellaneous] page, enable "Reduce
Memory Mode".

3. In "System Preference" dialog, specify "Work" from [Path] page.


Use "Reduce Memory Mode" even if "Work" is not specified, but in
such a case, the default temporary area of Windows will be used.
Therefore, it is recommended that you specify "Work".

4. Click [OK] in "System Preference" dialog. When changing the Work path, reboot the
application to reflect the changes.


Please note that a warning dialog might appear when Work folder
has only 500 MB or less storage capacity.
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2.4. Geometry Verification Mode
With Geometry Verification function, you can visualize the differences geometrically and
topologically by comparing the two models in such ways as before and after data translation,
and before and after modification.



Geometry Verification Mode, in which geometry comparison is performed, is
treated as an independent function of Analysis menu. Therefore, operations
that involve modifying elements or models cannot be done in Geometry
Verification Mode. In addition, menus other than view operations to check the
comparison results are restricted.

It is possible to switch to Geometry Verification Mode from any mode. Just select [Geometry
Verification Mode] ( ) from Geometry Verification menu.

When To Use Each Geometry Verification Mode

Geometry Verification Mode is offered in two types: "Detailed Comparison" and "Quick
Comparison".

• Quick Comparison: Ideal to identify the differences made through engineering changes

• Detailed Comparison: Ideal to identify the differences made through geometry healing in
data translation


Please note that the function "Quick Comparison" compares fewer check items
than "Detailed Comparison".
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2.4.1. Mode Switching

1. Select [Geometry Verification] > [Geometry Verification Mode] ( ) from the menu.

CADdoctor SX will switch to Geometry Verification Mode.

Geometry Verification toolbar will appear.



Click [Geometry Verification Mode] ( ) to exit Geometry Verification
Mode. CADdoctor SX will return to the mode in which you were working
earlier.
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2.4.2. Analyze Geometry Verification Result

This section explains the procedure to analyze the geometry verification result and view the
differences on geometry.

1. Select [Geometry Verification] > [Open Comparison Result] ( ) from the menu, or click
[Open Comparison Result] ( ) from Geometry Verification toolbar.

2. "Open" dialog will appear. Specify SampleResult.gvfx_sx in the <tutorial> folder and click
[Open].

This will switch automatically to Geometry Verification Mode. In "3D View" window, the left
sample model, which is before modification, has a soft wavy surface. The right sample
model, which is after modification, is a plane.

 Immediately after switching to Geometry Verification Mode, since
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[Synchronize Views] ( ) is enabled, all view operations are synchronized
on the left and right models.

Press [Synchronize Views] ( ) to disable the function. Left and right view
windows can be operated independently.

3. In [Main (Work)] panel, select "Face Distance" from the category list. Distance between the
left and right models is displayed in different colors according to the gap between faces.


By default, "Nearest Point Direction" is set to display by needles the nearest
point direction per point. Small deviations are shown in blue, and large
deviations in red.
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4. Press [Switch Direction/Contour] ( ) on the toolbar. Toggle the viewing mode to contour.


[Contour View] will fill in the gap and display the data based on [Nearest
Point Direction].


[Contour View] may take longer and consume more memory than [Nearest
Point Direction]. Therefore, please ensure to have sufficient memory when
running [Contour View] on a large model.

5. Change the display color settings for the verification results. Click [Settings] ( ) located at
top right of [Main (Work)] panel.

"Geometry Verification Setting" dialog will appear. Select [Viewing Setting(1)] page.

6. Change "Mid-range deviation color" from green to white, then click [Apply].
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The change on the display color of "Mid-range deviation color" will be reflected in "3D View"
window.

Change the display color of "Mid-range deviation color" to green, and click [OK].

Click [Switch Direction/Contour] ( ) on the toolbar to switch to [Nearest Point Direction].

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 34 | 156



7. Click [Switch 2view/1view] ( ) on the toolbar. "3D View" window will switch to single view
mode; only Left model will be shown, and the differences will be on it.



[1View] is useful when there is no need to look at the right model to
compare with or when you want to temporary use the full screen to check
the left model.

When [Switch 2view/1view] ( ) is enabled, [2View] is enabled. When
disabled, then [1View] is enabled. Please note that this function only
appears on the toolbar.

8. Switch the view mode to [Shading + Wireframe] ( ) on the toolbar.
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9. Press [Draw 2Model in 1View] ( ) on the toolbar.
Left and right models are displayed overlapping each other.



Depending on the geometry of the models being compared, it may be easier
to see the differences by overlapping them.

When [Draw 2Model in 1View] ( ) is enabled, the models will overlap
each other. When disabled, the models are independently displayed. Please
note that this function only appears on the toolbar.


Besides toggling this function for easier comparison, you can insert
indicators as markers.

Add and Remove Point Indicator

1. Click [Add Point Indicator] ( ) on the toolbar.

2. Select a vertex or an edge in Left view.
An indicator (light pink) will be created at the clicked location on Left model, and
the corresponding location on Right model.

3. Select a vertex or an edge in Right view.
An indicator (light blue) will be created at the clicked location on Right model, and
the corresponding location on Left model.
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4. Press [Remove All Point Indicators] ( ) on the toolbar to remove all indicators.

2.4.3. Detailed Comparison: Entire Model

Using the sample model which has the error "Gap: Edge and base surface", compare the
geometry before and after modification and check how the surface has changed.

Preparation

Select [File] > [Open] from the menu, or click [Open] ( ) on the toolbar. In "Open"
dialog, open " SampleM1.drfx_sx " in <tutorial> folder.
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1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
error is highlighted in red.

2. Click [Fit Face to Loops] ( ) on Navigation panel to modify the error.

A new surface is calculated, and the geometry of the surface is displayed and highlighted in
light blue on "3D View" window.

3. A confirmation dialog will appear. Click [OK].

The error is modified, and the category list is updated.
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4. Select [Geometry Verification] > [Geometry Verification Mode] ( ) from the menu to
switch to "Geometry Verification Mode".


The model on which you were working will be auto-set as Current model,
and shown in Left view.

Next, open the model that you want to compare.

5. Click [Open Right Model] ( ) on the toolbar.

6. "Open" dialog will appear. Change the file type to "CADdoctor SX Files (.drfx_sx)", then open
" SampleM1.drfx_sx " in the <tutorial> folder.

The selected sample model will be shown in Right view.
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 Also, to import a model, just drag-and-drop the model onto the right screen.

7. Set options for Geometry Verification.
Select [Geometry Verification] > [Settings] from the menu, or click [Setting] ( ) at the upper
right of [Main (Work)] panel.

8. "Geometry Verification Setting" dialog will appear. From [Verification Setting] page, select
"Detailed Comparison" in "Comparison Mode", and click [OK].

9. Run Geometry Verification.
Click [Begin Verification] ( ) at the lower left of [Main (Work)] panel.

The geometry verification result (number of detected differences of the corresponding
check criterion) will be shown in Category List upon the completion of geometry
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verification.

10. In [Main (Work)] panel, select "Face Distance" from the category list. Distance between the
left and right models is displayed in different colors according to the gap between faces.
Confirm that the surface has been modified to fit along the curved shape.



Click [Save Comparison Result] ( ) on the toolbar to save the comparison
result.

The saved comparison result file (.gvfx_sx) can be opened by clicking [Open
Comparison Result] ( ) on the toolbar.
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Run Geometry Verification upon Completion of Auto Heal

This section will explain the procedure to run Geometry Verification between models
before and after Auto Heal automatically upon completion of Auto Heal. Advantage of this
function is that you can shorten the running time rather than if you were to manually
save the drfx_sx file before auto healing and manually compare the geometry afterwards.

1. Press [Open] ( ) on the toolbar. Open SampleM2.drfx_sx from the <tutorial> folder.

2. Select [Modify] > [Options] from the menu. "Modification Settings" dialog will appear.
In [Auto-Heal(2)] page, enable the option "Compare to pre-modify model after healing"
and click [OK].


Please note that [Setting], which is located on the right of this option,
must be set before auto healing. Settings will not be changed here
because the default values will be used.

3. In [Main (Work)] panel, press [Auto Heal] ( ).

4. After auto healing is completed, "Auto Comparison" dialog will appear. Click [Yes].
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CADdoctor SX will switch to Geometry Verification Mode, and the geometry
verification result will be shown automatically upon the completion of geometry
verification.

5. After confirming the check result, once more select [Geometry Verification] >
[Geometry Verification Mode] ( ) from the menu. Close Geometry Verification Mode
and return to where you left off after auto healing.
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2.4.4. Detailed Comparison: Modified Areas Only

This section explains the procedure to analyze how much the surface is modified through
interactive healing of "Gap: Edge and base surface" areas by comparing the surface before and
after the interactive healing.
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Preparation

Select [File] > [Open] from the menu, or click [Open] ( ) on the toolbar. In "Open"
dialog, open " SampleM3.drfx_sx " in <tutorial> folder.

1. Select "Gap: Edge and base surface" from the category list in [Main (Work)] panel, and click
[Zoom current target] ( ).

The error is zoomed up.

First of all, store the "before modification" model internally.

2. Select [Geometry Verification] > [Target Model] > [Copy Current Model] ( ) from the
menu.
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

No change can be seen on CADdoctor SX, but the displayed model (before
modification model) is stored internally. This internally stored data is
displayed as "Target model (on right)" when switching to [Geometry
Verification Mode].

Next, modify the error. In this error, the surface is distorted, so modify the error by
replacing the surface.

3. Click [Recalculate Surface] ( ) from Repair Tool on Navigation panel.

A new surface is calculated, and the geometry of the surface is displayed and highlighted in
light blue on "3D View" window.

4. "Surface Recalculation" dialog will appear. To avoid reflecting the original surface in this
model, set "Original Surface Similarity" to "Less", and click [OK].

5. A confirmation dialog will appear. Click [OK].
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The error will be repaired. Verify the repaired areas once interactive healing is complete.

6. Select [Geometry Verification] > [Geometry Verification Mode] ( ) from the menu.

Switch to Geometry Verification Mode. Next, specify the face modified by interactive healing
as the part to be compared.


The model after interactive healing is displayed (on left), and the
unmodified model that was saved internally beforehand is displayed (on
right).
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7. Select [Geometry Verification] > [Partial Geometry Verification] from the menu.

8. Pick the face for comparison from the left model and press [Done] ( ).

9. Next, pick the face for comparison from the right model and press [Done] ( ).

Comparison of the two selected faces is executed.

10. In [Main (Work)] panel, select "Face Distance" and press [Zoom current target] ( ).
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The error is zoomed up.

When checking the differences, it can be confirmed that a maximum of about 0.05 mm of
geometry deformation has occurred.



By default setting, the minimum value is 0.005 mm and the maximum
value is 0.5 mm for the difference distance shown by the color bar.
Minimum and maximum values of the color scheme can be changed
according to the range of difference in distance in the displayed area.

The displayed color difference is not set properly, so change the setting.

11. Select [Geometry Verification] > [Settings] from the menu or press [Settings] ( ) located at
top right of [Main (Work)] panel.
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12. "Geometry Verification Setting" dialog will appear. In [Viewing Setting (1)] page, enable both
"Use Custom Color Range" and "Auto Scale Color" options, and then click [OK].

Color scheme of the color bar changes depending on the range of the difference distance.

13. After confirming the comparison result, once again select [Geometry Verification] >
[Geometry Verification Mode] ( ) from the menu.
Geometry Verification Mode ends, and you will return to the state after interactive healing.
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

Please note that when exiting Geometry Verification Mode, the model to be
compared displayed on the right screen is deleted, and at the same time,
the model stored internally is also deleted.

In case you want to keep the internally stored model after exiting
Geometry Verification Mode, select [Geometry Verification Mode] > [Target
Model] > [Store Previous Target Model] ( ).

When exiting Geometry Verification Mode with [Store Previous Target
Model] ( ) enabled, the internally stored model will not be deleted.

2.4.5. Quick Comparison: Entire Model

This section explains the procedure to run Geometry Verification in Quick Comparison mode on
the geometry between assembly models.


Please note that the function "Quick Comparison" compares fewer check items
than "Detailed Comparison".

Preparation

Select [Geometry Verification] > [Open Comparison Result] ( ) from the menu. In
"Open" dialog, open " SampleM4.gvfx_sx " in <tutorial> folder.

1. Select [Geometry Verification] > [Settings] from the menu, or click [Setting] ( ) at top right
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corner of [Main (Work)] panel.

2. "Geometry Verification Setting" dialog will appear.
In [Verification Setting] page, select "Quick Comparison" in Comparison Mode, then click
[Details] located on the right.

3. [Geometry Verification Setting] tab will appear in "Geometry Verification Setting" dialog.
Make sure that "Begin Feature Recognition" is enabled and click [OK].


Because "Begin Feature Recognition" was enabled in "Quick Comparison
Setting" dialog when running Geometry Verification, "Difference List" was
added to [Main] panel.

4. You will be returned to the main dialog. Click [OK] to close the dialog.

5. Press [Begin Verification] ( ) at the lower left of [Main (Work)] panel.

6. Double-click the part named "block" in [Main (Work)] panel.
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"3D View" window will be filtered to show the selected part "block" only to analyze the
geometry verification result per part.

Double-click the part named "sheet" in [Main (Work)] panel.

"3D View" window will be filtered to show the selected part "sheet" only to analyze the
geometry verification result per part.

7. Double-click "(Whole model)" in [Main (Work)] panel, and select Unique Faces in Category
list.
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The differences between the two models are highlighted in red.

8. Click [Zoom Current Target] ( ) at the bottom of [Main (Work)] panel.

"3D View" window will fit to the result area which is set to Current.



Click [Change to contents list] ( ) at top right corner of [Main (Work)]
panel. Contents List will show the list of differences of the selected
category.
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9. Click [Compare Current Region] ( ) at the bottom of [Main (Work)] panel.

The distance against the other model will be shown on Current error in "3D View" window.

Open [Difference List] panel.

10. Double-click a "Hole" in [Difference List] panel.

The error is zoomed up.
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
In [Difference List] panel, you can confirm the difference for each
recognized feature. Furthermore, models that have multiple parts can have
their comparison results displayed according to each part.

11. Open [Structure comparison] panel.

When selecting a part in [Structure comparison] panel, the corresponding part is
highlighted in blue on "3D View" window.

■ When selecting "block"

■ When selecting "sheet"
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
Parts on which difference(s) have been detected will be highlighted in
orange in the structure tree in [Structure comparison] panel.



Select [Show Geometric Differences] from the context menu in [Structure
comparison] panel to move to [Main (Work)] panel.
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3. Intermediate
This chapter will explain in detail how to modify errors using Interactive Healing functions.
With the knowledge you have gained up to this point, CADdoctor SX will let you translate most
of the data adequately.

3.1. Interactive Healing
This section will explain how to modify the error, "Gap: Edge and base surface", which tends to
occur quite often.



When errors "Loop with self-intersection" and "Surface with self-intersection"
are detected, these two errors must be modified first before any other error
items. If you modify other error items while these two types of errors exist, the
modification function may not work properly.

When "Loop with self-intersection" and "Surface with self-intersection" are not
detected, you can start modifying from any error items.

"Gap: Edge and base surface" is an error that often occurs during data translation, and there are
many modification functions to modify the error.

The characteristics of each function will be explained so that you can select the most
appropriate one for you.



• Please refer to "Check for Errors" in [Beginner] for more details about how
to check detected errors.

• Also, refer to "Interactive Healing" in [Beginner] for more details about the
general operation of interactive healing.
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3.1.1. Fit Face to Loops

Preparation

Select [File] > [Open] from the menu, or click [Open] ( ) on the toolbar. In "Open"
dialog, open " FitFaceToLoops.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

You can see that there is a gap between the edge (shown in red) and the surface (shown in
white).

2. In this case, use [Fit Face to Loops] ( ) to modify the error.


The function [Fit Face to Loops] finely adjusts the position of control points
on the surface or increases the number of control points. This function is
versatile, and it can modify almost all "Gap: Edge and base surface".

3. Select [Modify] > [Gap between Edge and Surface] > [Fit Face to Loops] or click [Fit Face to
Loops] ( ) from Repair Tool on Navigation panel.
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A new surface is calculated and its boundary is highlighted in light blue on "3D View"
window.

4. A confirmation dialog will appear. Click [OK].


The maximum gap value (Gap: Edge and base surface) after replacing the
surface with a new one will be shown in the confirmation dialog.

The error is modified and the category list is updated.



Most of the errors in "Gap: Edge and base surface" can be modified with
[Fit Face to Loops]. However, if you want to keep the shape of design
intentional surface or a cylindrical / spherical surface, use the functions
[Extend Surface] or [Project Edge on Surface] to modify.
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Fit Face to Loops and Control Points

To better understand the function [Fit Face to Loops], compare the control points before
and after modification.

1. To undo the modification after executing [Fit Face to Loops], select [Edit] > [Undo] (
).

2. In this case, select [Analysis] > [Control Points] > [Surface] ( ) and pick the surface
with an error. The control points before modification will appear.

3. Next, select [Edit] > [Redo] ( ) to go to the modified state.

4. Likewise, select [Analysis] > [Control Points] > [Surface] ( ). Pick a modified surface
to show its control points.

5. When comparing the surfaces before and after modification, you can see that the
number of control points has increased to modify "Gap: Edge and base surface".

Since [Fit Face to Loops] is performed by moving or increasing the number of control
points, it is not suitable for surfaces with poor quality control points.

(Reference) Surface with poor quality control points (Left: Control points + Semi
Transparent, right: Shading)
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3.1.2. Recalculate Surface

The function [Recalculate Surface] ( ) is used to recreate a surface based on a plane or a
cylindrical surface. Therefore, a surface which is closer to a plane or cylinder is better suited for
modification.


This function is mainly used to modify the errors "Surface with self-
intersection" and "Surface with singular point". It is recommended to use on
the error "Gap: Edge and base surface" when other functions cannot modify it.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " RecalculateSurface.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

The surface (in white) is oscillating greatly. In such a case, use [Recalculate Surface] ( ) to
modify the error.

2. Press [Recalculate Surface] ( ) on Navigation panel.

3. "Surface Recalculation" dialog will appear. To avoid reflecting the original abnormal
surface, move the slider toward "Less" for "Original Geometry Similarity", and click [OK].
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

The higher the dependency, the more the geometry of the original surface
is reflected, but the time required for calculation increases as well.
Normally, use the default settings, and if you want to reflect the geometry
of the original surface more accurately, increase the dependency.

On the other hand, if you don’t want to reflect the geometry because the
original surface is an invalid geometry, set the dependency toward "Less".

Also, if the quality of the generated surface is poor, adjusting the
dependency may improve the quality.

A new surface is calculated and its boundary is highlighted in light blue on "3D View"
window.

4. A confirmation dialog will appear. Click [OK].

Faces with "Surface with self-intersection" are replaced and all errors have been modified.
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3.1.3. Extend Surface

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " ExtendSurface.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

Confirm the face (red) protruding from the surface (white). In this case, use the function
[Extend Surface] ( ).
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2. Select [Modify] > [Divide/Extend] > [Extend Surface] from the menu or click [Extend
Surface] ( ) from Repair Tool on Navigation panel.

A new surface is calculated and its boundary is highlighted in light blue on "3D View"
window.

3. In addition, a "Confirmation" dialog will appear. Click [OK].


The maximum gap value (Gap: Edge and base surface) after replacing the
surface with a new one will be shown in the confirmation dialog.

The error is modified and the category list is updated.


Please note that [Extend Surface] ( ) can be used to extend cylindrical
and other analytical surfaces appropriately. Refer to A.2, “Analytic
Surfaces” in the Appendix for more details.
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3.1.4. Other Commands To Repair PDQ Errors

This section will give you a brief explanation of the commands which are not used very often.

Boundaries, Surface → Surface

The function [Boundaries, Surface → Surface] ( ) is used to create a new surface based
on the boundary edges and original surface.
This function is recommended when [Fit Face to Loops] ( ) does not work.

Below is a comparison result between [Fit Face to Loops] (lower left) and [Boundary,
Surface → Surface] (lower right). The modified surface is shown in light blue and can be
previewed.

Since [Fit Face to Loops] manipulates and modifies the control points, the geometry of the
surface hardly changes. On the other hand, [Boundary, Surface → Surface] recalculates to
define a new surface. If the quality of the control points is poor, it may be more
appropriate to use [Boundaries, Surface → Surface].

Furthermore, the function [Boundaries, Surface → Surface] cannot be used for faces with
complex boundary edges.

Boundaries → Surface

The function [Boundaries → Surface] ( ) is used to recreate the surface based on the
geometry of the boundary edges. 
Therefore, unlike [Boundaries, Surface → Surface] ( ), the geometry of the original
surface is not referenced at all.

Following figures show the result of modifying the surface with [Boundaries,
Surface→Surface] (upper right) and [Boundaries →Surface] (lower right) for the surface
with bulged center (left).
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This function is recommended for modifying the surface with invalid geometry such as
undulation and self-intersection.

Furthermore, like in the case with [Boundaries, Surface→Surface], the function cannot be
used for faces with complex boundary edges.

3.1.5. Project Edge on Surface

While other modifying functions for "Gap: Edge and base surface" modifies "Surfaces", the
function [Project Edge on Surface] ( ) only modifies "Edges". Therefore, please note that this
may cause errors in the related elements.

Mainly used for surface such as design intentional surface, cylindrical surface, and spherical
surface where you want to strictly maintain the geometry.

In the following, the characteristics and notes on [Project Edge on Surface] will be explained
along with examples of usage.

■ Example of "Project Edge on Surface" being used (1)

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " Projection.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.
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It is possible to confirm that the surface (white) and the curve (red) are apart. In such a case,
use [Project Edge on Surface] to project the curve onto the surface.

2. Select [Modify] > [Gap between Edge and Surface] > [Project Edge on Surface] from the
menu, or click [Project Edge on Surface] ( ) from Repair Tool on Navigation panel.

The preview of the projected edge will be shown in white in "3D View" window.

3. A confirmation dialog will appear asking whether to update the adjacent edges. Click [Yes].


Please note that when you click [No] in the confirmation dialog, only the
curves to be modified among the boundaries will be moved. This causes a
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separation in the boundary and detected as "Gap: In loop". When the
relevant edges are not updated, the error "Gap: In loop" may occur.

The curve to be modified and its relevant edges are moved.

Because the surface moved upward, there is a new gap between the adjacent edge and the
surface, increasing the number of errors in "Gap: Edge and base surface".

4. In [Main (Work)] panel, use [Next] ( ) and [Previous] ( ) to switch the following errors.

5. Click [Extend Surface] ( ) on Navigation panel.
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A new surface is calculated and its geometry is highlighted in light blue on "3D View"
window.

6. A confirmation dialog will appear. Click [OK].


The maximum gap value (Gap: Edge and base surface) after replacing the
surface with a new one will be shown in the confirmation dialog.

The error will be repaired, and the category list will be updated.

7. Repair the remaining "Gap: Edge and base surface" errors.

Click [Fit Face to Loops] ( ) on Navigation panel.

A new surface is calculated and its geometry is highlighted in light blue on "3D View"
window.
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8. A confirmation dialog will appear. Click [OK].

The error will be repaired, and the category list will be updated.

9. Repair the remaining "Gap: Edge and base surface" errors.

Click [Fit Face to Loops] ( ) on Navigation panel.

A new surface is calculated and its geometry is highlighted in light blue on "3D View"
window.
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10. A confirmation dialog will appear. Click [OK].

Now all the errors have been modified.

■ Example of "Project Edge on Surface" being used (2)

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " Projection2.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.
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
Click [Previous] ( ) / [Next] ( ) to change Current error when the error
highlighted in red in "3D View" window is not the one you wish to repair.

It is possible to confirm that the surface (white) and the curve (red) are apart. In such a case,
use [Project Edge on Surface] ( ) to project the curve onto the surface.

2. Press [Project Edge on Surface] ( ) on Navigation panel.

The projection result is previewed in white on "3D View" window.

3. A dialog confirming the update of relevant edges will appear. Click [No] in this case.
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

Please note that when an adjacent edge is close, as in the sample model,
and updated together, there is a possibility that the modification is not
adequate.

The error will be repaired, and the category list will be updated.

4. Repair the remaining "Gap: Edge and base surface" errors.

Click [Project Edge on Surface] ( ) on Navigation panel.

The projection result is previewed in white on "3D View" window.

5. A dialog confirming the update of relevant edges will appear. Click [No] in this case.
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The error is modified and the category list is updated.

All "Gap: Edge and base surface" will be modified; however, because the relevant edges
have not been updated, a new error "Gap: In loop" is detected.

6. Repair the "Gap: In loop" error. In [Main (Work)] panel, select "Gap: In loop" from the
category list. Target position is highlighted in red on "3D View" window.

7. Press [Merge Edge Terminals] ( ) on Navigation panel.

A curve is inserted into the long and narrow face to modify the error "Gap: In loop".
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Now all the errors have been modified.



The error "Gap: Edge and base surface" can be modified by the function [Fit
Face to Loops] ( ) as well. However, when you modify with [Fit Face to
Loops], the surface may deform slightly and may not be a cylindrical surface.

To keep the cylindrical surface as in the sample model, use [Project edge on
Surface] ( ) to modify the geometry of the surface.

When confirming from [Analysis] > [Info] ( ), you can see that the surface
modified with [Project Edge on Surface] (lower left) has not changed from the
"Cylindrical Surface", while the surface modified with [Fit Face to Loops]
(lower right) has changed to "NURBS".
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3.2. Suitable Method
The following three ways allow you to check whether the appropriate modification method had
been applied to an error.

• Error message during modification

• Surface geometry after modification

• Increase or decrease of detected errors

■ Error message during modification

For example, when using [Boundaries, Surface → Surface] ( ) to modify a face with complex
boundaries, the following error message will appear. You will notice that the method is
inappropriate.

■ Surface geometry after modification

For example, as a result of executing [Fit Face to Loops] ( ) , a large oscillated surface may be
calculated, as shown in the figure below. In such a case, cancel the modification and execute
other modification functions.

■ Increase or decrease of detected errors

Since the error caused by modification is automatically detected, confirm whether the
modification was appropriate by looking at the increase or decrease in the number of errors in
the category list on [Main (Work)] panel.



Please note that just because the number of errors increased does not
necessarily mean that the function is inappropriate. For example, as seen in
[Project Edge on Surface] ( ), an error "Gap: In loop" may be detected after
execution due to the nature of modification.
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When the repair icon does not appear

Although an error item is selected from the category list, the repair icon may not appear
on Navigation panel for the following reasons:

• Before performing Auto Healing

With the exception of some functions, you cannot perform interactive healing before
auto healing.

• Severity is "Minor"

For some minor error items, there aren’t any dedicated modification functions
because the data can be successfully passed to the output system without modifying
the error.
However, try to design the product in such a way as to prevent errors from occurring
because they may cause problems in the post processes such as analyzing,
manufacturing, etc.


Please refer to A.1, “Error Items” in the Appendix for details about
the severity level of error items.

• Errors that can be modified by modifying other error items

Repair icon may not appear because it is possible to modify an error by modifying
another error. An example would be "Gap: Edge and base surface" which can be
modified by modifying "Gap: Vertex and surface".

• Items that cannot be modified

If there are no appropriate modification function, the repair icon will not appear.
Check the errors and modify them with the source CAD system if necessary. For
example, CADdoctor SX cannot modify the error where the inner loop protrudes over
the outer boundary. (Below left figure)

Such an error is detected as "Intersecting loops", so make modification such as
changing the size and position of the inner loop in the source CAD system.
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3.3. Useful Tools
This section will show you some useful tools available for Interactive Healing with CADdoctor
SX.

3.3.1. Pick Filter

Pick Filter will allow you to filter the target elements to be selected on "3D View" window. To
multiselect the target elements, it will be easier to select by limiting the target elements in Pick
Filter.

(Example) When deleting unnecessary single points

1. Select [Edit] > [Delete] from the menu or select [Delete] ( ) on the toolbar.

2. In [Option] panel, select "Specify target elements".

3. Switch the Pick Filter to "Vertex".

4. At the upper right of "3D View" window, press [Area Selection Mode] ( ). Left-click and
drag to enclose the points you want to delete.
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
Also, select elements by left-clicking while holding down [Ctrl] key and
dragging to enclose with a rectangle.

5. Press [Done] ( ). Only points within the selected area will be deleted.

3.3.2. Clipping Box

Clipping Box will allow you to display only those elements that are contained in a rectangle
(clipping box) centered at a specified position. The position, shape and angle of Clipping Box can
be adjusted freely.

■ How to Use Clipping Box

1. Select [View] > [Edit Clipping Box] from the menu or select [Edit Clipping Box] ( ) on the
toolbar.

The Clipping Box and "Edit Clipping Box" dialog will appear on "3D View" window.


Please note that the size of Clipping Box is automatically determined by the
size of "3D View" window.

2. Move the handles inside Clipping Box to adjust the size and orientation of the box.
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
◦ Yellow handle: Handle for changing the size

◦ Gray handle: Handle for adjusting the angle

3. After editing, click [Close] in the "Edit Clipping Box" dialog to finish the positioning. Only the
elements contained within the clipping box will be displayed on the 3D view.

While the displayed area is limited, perform such actions as deleting elements inside the
model.



Select [View] > [Clipping Box (On/Off] from the menu or enable [Clipping
Box (On/Off)] ( ) on the toolbar. Only the elements inside Clipping Box
are displayed.
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4. Advanced
Most CAD data can be properly translated using the modification methods you have learned up
to the "3, Intermediate" level. However, more sophisticated operations may be required
depending on the state of the source data.

This chapter will explain how to modify errors that require technical operations in the form of
case studies.


Please note that [Auto Stitch] ( ) and [Auto Heal] ( ) have been processed
on the sample models (*.drfx_sx) for the advanced course.

4.1. Modifying Free Edge
When importing data that do not have connection information between faces, it is possible to
combine free edges by [Auto Stitch] ( ). However, it may not be possible to combine all free
edges.

4.1.1. Case: Missing Face

When importing a file such as IGES, the face may be missing at the fillet position, etc. If the face
is missing, the boundary is recognized as "Free edge".

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " FillHole.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.
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
In this sample model, the face is missing in the fillet position. Fill in the face
to modify the error.

2. Press [Fill Hole (Create New Face)] ( ) on Navigation panel.

3. A confirmation dialog will appear. Confirm that the edges you want to fill are highlighted
correctly on "3D View" window, and click [OK].

A new face is created in the target position, and the category list is updated.
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4.1.2. Case: Duplicate Faces

When importing such files as IGES file, the faces may be duplicated.
When the faces are duplicated in this way, the boundaries without adjacent faces are
recognized as free edges.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " RemoveDuplicateFace.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.


Faces are duplicated in this position. In this case, delete one of the
duplicated faces, and update the connection information between the faces
with [Auto Stitch].


When finding the duplicated position is difficult, select [View] > [Regen]
( ) from the menu to update the "3D View" window.

2. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

3. In [Options] panel, select "Specify target elements".
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4. Pick the duplicated face on "3D View" window, and press [Done] ( ).
* In this case, delete either of the face.



To specify a face to delete, right-click on the duplicated face and "Pick
Which?" dialog will appear. Specify the candidate in the dialog.

One face has been deleted. Press [Quit (Esc)] ( ) to exit the command.

5. In [Main (Work)] panel, press [Auto Stitch] ( ).
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6. "Auto Stitch" dialog will appear. Specify "Tolerance" to 0.01 mm and click [Try].

7. Make sure that "After auto-stitch: Free edges" is "0", and click [Fix].

Auto stitching is executed, and the category list is updated.



After stitching, if the face direction needs to be modified, select [Modify] >
[Repair Solid] > [Flip Face] ( ) to reverse the face.

Please refer to "Flip Face" for more details.
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4.1.3. Case: Fail to Trim

When importing files such as IGES, faces which fail to be trimmed may exist. In this case, the
boundary of the face that failed to be trimmed is recognized as a free edge.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " FailToTrimSurface.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.

2. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

3. Pick the face that has failed trimming on "3D View" window.

4. Pick the edges to use as the new boundary, and press [Done] ( ).
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5. A confirmation dialog will appear.
Confirm that the edge(s) to use for the new face boundary are highlighted in light blue in
"3D View" window, and click [OK].


Click [Prev.] / [Next] when the edge(s) highlighted in light blue in "3D View"
window is not the one(s) you wish to use as the new boundary of the
selected face.

6. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].


Click [Prev] / [Next] when the face highlighted in blue in "3D View" window
is not the one you wish to keep.
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The boundary has been modified. Click [Quit (Esc)] ( ) to exit the command.

Please note that a part of the modified face boundary still remains as free edge(s).

7. Update the new boundary’s connection information. In [Main (Work)] panel, click [Auto
Stitch] ( ).

8. "Auto Stitch" dialog will appear. Specify "Tolerance" to 0.01 mm and click [Try].

9. Confirm that "After auto-stitch: Free edges" is "0", and click [Fix].

Auto stitching is executed, and the category list is updated.
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4.1.4. Case: Huge Gap between Edges

When faces cannot be stitched by auto stitching due to the large gap between the edges, the
position is recognized as a free edge.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " EdgeStitch.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.


[Auto Stitch] does not work for this error because the gap between edges to
stitch is too large. In such case, stitch with [Stitch (pick)] in [Navigation]
panel by specifying the edges to stitch manually.



Shortest distance between the edges is approximately 0.3 mm. Select
[Analysis] > [Distance] ( ) to measure the distance between the two
edges.
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2. Select [Modify] > [Repair Solid] > [Stitch (pick)] from the menu or click [Stitch (pick)] ( )
on the toolbar.

3. For the first edge, pick both [1] and [2] on "3D View" window.

Next, for the second edge, pick [3] on "3D View" window. Press [Done] ( ).



It is also possible to stitch edges that are far apart by loosening the
tolerance and performing auto stitching; however, because auto stitching
covers all edges that have no connection, if the tolerance is too loose, the
edges may be stitched together with the wrong edges than what the
designer intended.

Edges [1]～[3] are stitched together, and the category list is updated.


Please note that for models that are not originally solids, such as an IGES
file output from a surface model, the outer free edges will remain after
auto stitching, but this is not an error and does not need to be modified.
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4.1.5. Case: No Adjacent Faces

When a model is not originally a solid, such as an IGES file output from a surface model, the
outer free edges may remain because there are no adjacent faces.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " FaceTrim.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.



Because the planar face is not adjacent to the hemispherical protrusions,
the position around the two hemispherical protrusions are recognized as
"Free edge". Errors can be modified by retrimming the faces so that they
are adjacent to the hemispherical protrusions.


Select [Analysis] > [Related Element] from the menu or click [Related
Element] ( ) on the toolbar. Confirm the element related to the specified
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element. After modification, you can confirm that both faces are adjacent
to the hemispherical protrusion. (before modification → after modification)

When it is difficult to see the details with the free edges highlighted in red,
click [Indicate Current Target] ( ) in [Main (Work)] panel.

The highlight in "3D View" window will be disabled, and Current area will
be deselected.

How to modify Face A and B.

■ Change Boundary of Face A

Modify the boundary of Face A according to the geometry of hemispherical protrusion.

1. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

2. Select Face A on "3D View" window.
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3. Pick a curve (light blue edge) that intersects the existing boundary, and press [Done] ( ).

4. A confirmation dialog will appear. Confirm that the trimming position is the same as the
image below, and click [Yes].

5. Select the edge that will be the boundary of the new face (pink edge).
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6. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

7. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].

Face A boundary has been modified. Press [Quit (Esc)] ( ) to exit the command.
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■ Change Boundary of Face B

As with Face A, modify the boundary of Face B to match the geometry of the hemispherical
protrusion.

1. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

2. Select Face B on "3D View" window.

3. Pick a curve (light blue edge) which intersects with the existing boundary, and press [Done]
( ).

4. A confirmation dialog will appear. Confirm that the edge highlighted on "3D View" window
is correct, and click [OK].

5. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
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blue in "3D View" window) is set appropriately, and click [Keep selected face].

Boundary of Face B has been modified.

Finally, use the same procedure to modify Face B so that the hemispherical protrusion at the
bottom right connects with the face.

6. Again, select Face B on "3D View" window.

7. Pick an edge from the outer boundary of the hemispherical protrusion at the bottom right of
the model, and press [Done] ( ).
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8. A confirmation dialog will appear. Confirm that the edge highlighted on "3D View" window
is correct, and click [OK].

9. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].

Boundary of Face B has been modified. (before modification → after modification)
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

The adjacency relation between the planar face and the hemispherical
protrusions have been repaired, and "Free edge" errors remain only on the
outer boundary of the planar face, which are not PDQ errors, therefore,
you can leave them as they are.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 99 | 156



4.2. Modifying Invalid Geometry
In some cases, the imported CAD model may have unpreferable geometry such as wavy curves.
This section will explain how to modify them.

4.2.1. Modify Curve with Oscillation (1)

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " InvalidGeometry1.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.



The face in the center of "3D View" window intersects itself. Furthermore,
when you zoom up the tip of that face, you can see the curves oscillating.
Such oscillations are undesirable for data quality.

Create a curve which replaces the oscillating curve on both sides of the surface.
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2. Select [Create] > [Curve] > [On Surface] from the menu or click [On Surface] ( ) on the
toolbar.

3. Select the face on the left. Pick two places on the curve as shown below, and press [Done]
( ).

4. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].

A new curve is created. Next, create a new curve on the right side of the face as well.

5. Select the face on the right. Pick two places on the curve as shown below, and press [Done]
( ).
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6. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].

A new curve is created. Press [Quit (Esc)] ( ) to exit the command.

Next, the two newly created curves will be used to replace the boundaries of adjacent faces.

7. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

8. Select the center face on "3D View" window. Pick the two newly created curves, and press
[Done] ( ).
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9. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].

10. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].

11. "How to treat detected gap" dialog will appear. Here, select "Ignore gap" and click [OK].

Boundary of the center face has been replaced by the two curves you created.
With the same procedure, replace the two newly created curves as the boundaries of the
adjacent left and right faces.
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12. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

13. Select the left face on "3D View" window. Pick the edge which will be the boundary of the
new face, and press [Done] ( ).

14. A confirmation dialog will appear. Confirm the edges highlighted on "3D View" window are
correct, and click [OK].

15. "Change Face Boundary" dialog will appear. Click either [Next] or [Previous] to switch to the
state where the face you wish to keep is highlighted in blue. Click [Keep selected face].
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Boundary of the face will be changed. With the same procedure, replace the boundary of the
right face.

Two newly created curves have replaced the boundaries of the adjacent faces.

16. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.

17. Press [Recalculate Surface] ( ) on Navigation panel.
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18. "Surface Recalculation" dialog will appear. Without changing "Original Surface Similarity",
click [OK].

19. A confirmation dialog will appear. Click [OK] as is.

The face with "Surface with self-intersection" is replaced, and all errors have been modified.

4.2.2. Modify Curve with Oscillation (2)

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " InvalidGeometry2.drfx_sx " in <tutorial> folder.
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

Although this model does not have any detected errors in the category list,
when visually observing the geometry on "3D View" window, you can see that
some of the edges shared by the left and center faces are oscillating. Curve
oscillation (Shading and Control Points)

Also, the adjacent faces are oscillating so even if you create new curves with
the function [On Surface] ( ), distorted curves will be created.

In such a case, create curves that replace the oscillating curves on both sides of
the surface.

1. Select [Create] > [Point] > [Division] from the menu or click [Division] ( ) on the toolbar.

2. Pick a curve (cyan color) with oscillation on "3D View" window.

3. "Enter Number of Segments" dialog will appear. Enter "10" and click [OK].
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Division points are created on the specified curve. Press [Quit (Esc)] ( ) to exit the
command.



In this case, there are nine points created because "10" was specified as the
number of segments.

4. Select [Create] > [Curve] > [Interpolation] from the menu or click [Interpolation] ( ) on the
toolbar.

5. On "3D View" window, pick in the order of "Start" point > created points > "End" point, then
press [Done] ( ).



Please ensure to exclude the point where the curve is oscillating.

6. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].
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An interpolation curve is created. (Curve on the side highlighted in light blue)

Press [Quit (Esc)] ( ) to exit the command.
Next, replace the edge shared by the left and center faces with the created interpolation
curve.

7. Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

8. Select the left face on "3D View" window. Pick the edge to use for new boundary, and press
[Done] ( ).

9. A confirmation dialog will appear. Confirm the curve highlighted on "3D View" window is
correct, and click [OK].
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10. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].


Click [Prev] / [Next] when the face highlighted in blue in "3D View" window
is not the one you wish to keep.

11. "How to treat detected gap" dialog will appear. Here, select "Ignore gap" and click [OK].

The boundary of the left face will be replaced by an interpolation curve.

12. Replace the boundary of the face in the middle by an interpolation curve in the same
procedure.
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Boundary of the center face has been replaced by the interpolation curve.

Press [Quit (Esc)] ( ) to exit the command.
Next, modify the error "Gap: Edge and base surface" which appeared when the face
boundary was replaced.

13. In [Main (Work)] panel, select "Gap: Edge and base surface" from the category list. Target
position is highlighted in red on "3D View" window.

14. Press [Boundaries, Surface → Surface] ( ) on Navigation panel.


Please note that due to the poor quality of the original control points, the
function [Boundaries, Surface → Surface] is more suitable than [Fit Face to
Loops].
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15. A confirmation dialog will appear. Click [OK].

Surface is replaced, and the category list is updated.

Finally, delete the unnecessary division points.

16. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

17. In [Options] panel, select "Specify target elements".

Switch the Pick Filter to "Vertex".

18. On "3D View" window, press down [Ctrl] key while left-clicking the mouse and drag around
the points to be deleted. Press [Done] ( ).

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 112 | 156



Points within the selected range have been deleted. Press [Quit (Esc)] ( ) to exit the
command.



Please note that only single elements can be deleted. Following dialog will
appear if the element includes non-single elements.



Elements other than solids can be deleted from the structure tree on [Main
(Structure)] panel. For example, right-click on the single element ( ) you
wish to delete on [Main (Structure)] panel, and click [Remove] from the
context menu.
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4.3. Modifying Invalid Topological Structure
Unintended topological structure model may be generated as a result when inappropriate
Boolean operation is executed in the source CAD system. This section will explain how to
modify the errors.

Example of Boolean Operation Generating Unintended Data

■ Logical Negation(NOT)

If there is an area where Solid A (blue) and Solid B (gray) overlap, a Boolean operation
"logical negation (NOT)" produces the result as shown below.

However, if Solid A (blue) and Solid B (gray) do not completely overlap, such as when they
touch each other at the top, tiny areas like the one shown below may remain due to
calculation errors.

■ Logical Disjunction (OR)

If there is an area where Solid A (blue) and Solid B (gray) overlap, a Boolean operation
"logical disjunction (OR)" produces the result as shown below.

However, if the size and position of Solid B (gray) are improper, Solid B may merge
incompletely, resulting in a tiny gap as shown in the figure below.
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To avoid such a result, when using Boolean operation, the solids should have an overlapping
area. Afterward, it is recommended that you visually observe the result.

The following explains how to modify the geometry caused by the Boolean operation.

4.3.1. Modifying Invalid Geometry Caused by Negation

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " boolean1.drfx_sx " in <tutorial> folder.



Zoom in to the area surrounded by the yellow circles to see where the Boolean
operation was intended and where it failed. In the area surrounded by the
yellow circle in the figure below, the result of the Boolean operation is not as
intended and the unnecessary faces remain.

In such case, delete the unnecessary face(s) left due to a failure in Boolean
operation.

1. Select [Modify] > [Divide / Extend] > [Divide Face] from the menu or click [Divide Face] ( )
on the toolbar.

2. Pick the target face on "3D View" window.
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3. Left-click the position where you wish to divide on the face.

4. A guide to divide direction will appear. Click the guide at the position where you want to
divide the face, and press [Done] ( ).

5. A confirmation dialog will appear. Enable "Apply to all" and click [Yes].
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6. Repeat the same procedure to divide the other side of the face.

Press [Quit (Esc)] ( ) to exit the command.
Next, delete the unnecessary face from the divided faces.

7. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

8. In [Options] panel, select "Specify target elements".

Switch the Pick Filter to "Face".
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9. Pick the face to delete on "3D View" window, and press [Done] ( ).



Please note that you need to delete the tiny faces hidden under the big face.

Faces are deleted. Press [Quit (Esc)] ( ) to exit the command.

10. In [Main (Work)] panel, select "Short curve" from the category list. Target position is
highlighted in red on "3D View" window.

11. Press [Remove Short Edge] ( ) on Navigation panel.
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All errors have been modified.

4.3.2. Modifying Invalid Geometry Caused by Logical Disjunction

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " boolean2.drfx_sx " in <tutorial> folder.



When zooming into the yellow circle, the result of the Boolean operation
(logical disjunction) is not as intended and a tiny gap is created, so the face is
extended into the gap.
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In such case, repair the tiny gap(s) produced due to a failure in Boolean
operation.
Detected error in this sample model can be modified by either [Remove Faces
With Fix] ( ) or [Change Face Boundary] ( ).

■ When modifying with [Remove Faces With Fix] ( )

1. In [Main (Work)] panel, select "Acute face connection" from the category list.
Press [Zoom current target] ( ) to highlight the target position (below figure) on "3D View"
window.

2. Press [Remove Faces with Fix] ( ) on Navigation panel.

Tiny gaps have been filled in and unnecessary parts of extended faces have been removed.


Please note that items marked as "Minor" in the category list are not errors
and do not need to be modified.

■ When modifying with [Change Face Boundary] ( )

1. In [Main (Work)] panel, select "Acute face connection" from the category list.
Press [Zoom current target] ( ) to highlight the target position on "3D View" window.
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2. Press [Change Face Boundary] ( ) on Navigation panel.

3. Pick the face you wish to divide on "3D View" window.

On "3D View" window, pick the edge to use for the new boundary, and press [Done] ( ).

4. A confirmation dialog will appear. Confirm that the edges highlighted on "3D View" window
are correct, and click [OK].
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5. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].


Click [Prev] / [Next] when the face highlighted in blue in "3D View" window
is not the one you wish to keep.

The boundary has been modified. Press [Quit (Esc)] ( ) to exit the command.

6. In [Main (Work)] panel, select "Edge used more than twice" from the category list. Target
position is highlighted in red on "3D View" window.

7. Press [Unstitch] ( ). Edges highlighted in red will be unstitched.
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8. In [Main (Work)] panel, select "Free edge" from the category list.

In [Main (Work)] panel, enable [Display Surroundings Only] ( ). To display the position of
errors, use [Next] ( ) and [Previous] ( ) to switch the currently displayed error position.

9. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar. On "3D View"
window, pick the unnecessary part of the face you just trimmed, and press [Done] ( ).

The face is deleted. In [Main (Work)] panel, disable [Display Surroundings Only] ( ).
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10. In [Main (Work)] panel, select "Free edge" from the category list.

11. In [Main] panel, press [Auto Stitch] ( ).

"Auto Stitch" dialog will appear. Specify the tolerance to "0.01 mm" and click [Try].

Confirm that the number of free edges is "0" and click [Fix].

Connection information between faces has been modified, and all errors have been
modified.
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5. More Advanced
Most CAD data can be translated properly with the modification methods used up to the "3,
Intermediate" level. In addition, even in cases where an element is missing and cannot be easily
modified, you can modify it by combining several functions.

This chapter will explain how to modify errors that require higher technical operations than "4,
Advanced" in the form of case studies.

5.1. Modifying Complex Errors

5.1.1. Case: Complex Face Missing

When importing a file such as IGES, there may be a face missing, and at the same time, there
may be a trimming failure. This section will explain how to modify these errors to make them
into solids.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " FillHole2.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Free edge" from the category list. Target position is
highlighted in red on "3D View" window.


In this sample model, there is a missing face and an incorrect trimming in
the step area.
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First of all, modify the area missing a face.

Begin by creating a curve (auxiliary line) necessary to create the face.

2. Select [Create] > [Curve] > [Perpendicular Line] from the menu or click [Perpendicular Line]
( ) on the toolbar.

3. On "3D View" window, pick a point which will be the tip of the vertical line. Pick the edge to
where you want to extend down the vertical line.

A vertical line is created and the edge to which the line is extended down is divided.
Press [Quit (Esc)] ( ) to exit the command.

Next, create a curve to divide the face.

4. Select [Create] > [Curve] > [On Surface] from the menu or click [On Surface] ( ) on the
toolbar.

5. On "3D View" window, pick the face you want to divide. (* From here, some faces are
hidden.
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Pick two points that will be the end points of the line on surface, and press [Done] ( ).

6. "Decide Tangent Vector" dialog will appear. Accept the default setting and click [OK].

A new curve is created. Press [Quit (Esc)] ( ) to quit the command.

Next, divide the face with the new created curve.

7. Select [Modify] > [Divide / Extend] > [Divide Face] from the menu or click [Divide Face] ( )
on the toolbar.
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8. On "3D View" window, pick the face you wish to divide. Next, pick the created line on
surface, and press [Done] ( ).

The face has been divided. Press [Quit (Esc)] ( ) to quit the command.

Next, delete the unnecessary face.

9. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

10. On "3D View" window, pick the face to delete, and press [Done] ( ).

The face has been deleted. Press [Quit (Esc)] ( ) to quit the command.

CADdoctor SX Tutorial -Standard function-

 © 2024 Elysium Page 128 | 156



Finally, create a face where the face is missing.

11. Select [Create] > [Face / Surface] > [Fill Hole (Create New Face)] from the menu or click [Fill
Hole (Create New Face)] ( ) on the toolbar.

12. "Option" dialog will appear. Select "Auto detect".

13. On "3D View" window, pick an edge where the face is missing, and press [Done] ( ).

14. A confirmation dialog will appear. On "3D View" window, confirm that the edges you want
to fill in are highlighted correctly, and click [OK].
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A new face is created in the target position.

15. Follow the same procedure to create a face for the other opening.

A new face is created in the target position, and the category list is updated.

Press [Quit (Esc)] ( ) to exit the command.
This concludes the modification of missing faces.


In the following sections, you will use the sample model which you have
repaired so far. So, save the repaired sample model under a different name
as required.
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5.1.2. Case: Overly Shared Edges

* Continue using the sample model " FillHole2.drfx_sx " which you have just modified the
missing face.

1. In [Main (Work)] panel, select "Edge used more than twice" from the category list. Target
position will be highlighted in red on "3D View" window.



This edge is shared by three faces. One of these faces is inside the CAD
model; therefore, the face inside the model is not needed.

In this case, delete the unnecessary face existing inside the CAD model.

2. Press [Delete Elements] ( ) in Auxiliary Tool on Navigation panel.

3. If you move the mouse cursor over on the edge highlighted in red on "3D View" window,
"Multiple options" will appear.
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Right-click the mouse in that state to display "Pick Which?" dialog.

Specify the face existing inside the model in "Pick Which?" dialog, and press [Done] ( ).

Specified face is deleted, and the category list is updated. Press [Quit (Esc)] ( ) to quit the
command.

This concludes the modification of overly shared edges.
Finally, recreate the two divided faces into a single face.

4. Select [Modify] > [Replace Surface] > [Recalculate Surface] from the menu or click
[Recalculate Surface] ( ) on the toolbar.

5. On "3D View" window, pick the two divided faces, and press [Done] ( ).
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6. "Surface Recalculation" dialog will appear. Click [OK] without changing "Original Surface
Similarity".

A confirmation dialog will appear. Click [OK].

Surfaces are swapped, and two faces are replaced with one.
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5.1.3. Case: Loop with Self-intersection

■ Modify with "Clean Self-intersection"

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " LoopIS.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.



This model has an elongated face with an edge intersecting in the center,
which has been detected as an error.

2. Click [Clean Self-intersection] ( ) on Navigation panel.
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The self-intersecting loop will be repaired, and the face will be divided into two faces (Face
[1] and Face [2]) at the intersection. Category List will be updated.

3. Select "Acute face connection" in Category List, and the newly detected "Acute face
connection" errors will be highlighted in red in "3D View" window.



Confirm that the elongated face (Face [1]) and the large face on the left are
connected at an acute angle.

Delete the elongated face (Face [1]), and connect the large faces on both
sides.
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Confirm the positional relation of surrounding elements

a. Select [Analysis] > [Related Element] from the menu or click [Related Element]
( ) on the toolbar.

b. By picking a face, the edges and vertices related to the picked face will be
highlighted.

In the edge (C1) near the center of the figure below, you can see a large face each
on the left and right which are trimmed so that they overlap each other.

When adding "Duplicate Faces" to Check items, you can detect where the faces
overlap.


To add or delete an error in the category list, select [Check] >
[Options] (in Data Translation Mode). In [Check items] page, set
the preferred setting.

4. Press [Delete Elements] ( ) in Auxiliary Tool on Navigation panel.

5. If you move the mouse cursor over on the edge highlighted in red on "3D View" window,
"Multiple options" will appear.
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Right-click the mouse in that state to display "Pick Which?" dialog.
Specify (Face [1]) in "Pick Which?" dialog, and press [Done] ( ).

6. Specified face is deleted and the category list is updated. Press [Quit (Esc)] ( ) to quit the
command.

7. Select [Modify] > [Repair Solid] > [Stitch (pick)] ( ) from the menu.

8. Pick one of the edges tangent to the deleted (Face [1]), and press [Done] ( ). Similarly, pick
the other edge, and press [Done] ( ).

The edges are connected, and the category list is updated.
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

Please note that although several "Free edge" errors still remain, since they
are the boundaries of the sample model (sheet), these errors do not need to
be modified.

■ Modify with "Divide Face"

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " LoopIS2.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.
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Confirm the positional relation of surrounding elements around this error.

2. Select [Analysis] > [Related Element] from the menu or click [Related Element] ( ) on the
toolbar.

3. PIck the vertex that is highlighted in red. Five edges (C0-C4) related with that vertex are
highlighted.



Since this point shares the vertex of the edges that make up the loop, it is
detected as "Loop with Self-intersection".

[Clean Self-intersection] ( ) can be used to modify this error. But in this
case, use [Divide Face] ( ).

4. Press [Divide Face] ( ) on Navigation panel.

5. On "3D View" window, pick the vertex highlighted in red.

Two dotted lines are displayed around the picked vertex. Pick the dotted line in the direction
you want to divide the face, and press [Done] ( ).
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6. The face is divided by the dotted line, and a confirmation dialog will appear. Enable "Apply
to all", then click [Yes].

The base surface becomes smaller, and the category list is updated.



Please note that if the four edges that share a vertex result in having
different faces, it’s also possible to modify the position and direction of the
face division as shown below.
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■ Modify with "Recalculate Surface"

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " LoopIS3.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Loop with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.



When zooming into the target, you can see that Edge [1] and Edge [2] are
intersecting.

Self-intersection at this position is caused by a distortion of Edge [1]. In this
case, Edge [1] will be modified by recalculation.

2. Press [Recalculate Surface] ( ) in Repair Tool on Navigation panel.
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3. In [Option] panel, select "Interpolate".

4. Pick Edge [1] on "3D View" window.

5. "Input Number of Division" dialog will appear. Use the default value "10", and click [OK].

6. Nine passing points are shown, dividing Edge [1] into ten segments.
Pick all nine passing points or enclose the area range, and press [Done] ( ).

7. Recalculated Edge [1] is displayed in light blue and can be previewed. A confirmation dialog
will appear. Click [OK].
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Edge [1] is replaced, and [Loop with self-intersection] is modified.

Next, modify the boundary of existing face and fill in the missing parts of the face.
First of all, create an edge that will be the new boundary of the face.

8. Select [Create] > [Curve] > [Interpolation] from the menu or click [Interpolation] ( ) on the
toolbar.

9. On "3D View" window, pick points (Start point / End point) at the position where you want to
create a curve, and press [Done] ( ).

10. "Decide Tangent Vector" dialog will appear. Click [Select edge] next to "Start".
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Pick an existing edge that connects to the curve you just created. Tangent direction of the
new curve is updated to connect smoothly with the existing edge.

Click [OK] in "Decide Tangent Vector" dialog.

A new curve is created. Click [Quit (Esc)] ( ) to exit the command.

11. Replace the face boundary by the created curve.
Select [Modify] > [Repair Solid] > [Change Face Boundary] from the menu or click [Change
Face Boundary] ( ) on the toolbar.

12. On "3D View" window, pick the face whose boundary you wish to change.

13. Pick the curve you just created and the edges that connect to it, and press [Done] ( ).
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14. A confirmation dialog will appear. Confirm that the new boundary edges are highlighted on
"3D View" window, then click [OK].

15. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].

Boundary of the face has been changed.
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16. With the same procedure, use [Interpolation] ( ) and [Change Face Boundary] ( ) to fill
the holes.

When all holes are filled, the number of detected errors is "0" in the category list.

5.1.4. Modifying Surface with Self-intersection

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " SurfaceIS.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Surface with self-intersection" from the category list. Target
position is highlighted in red on "3D View" window.
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

Zoom into the target position and confirm the face self-intersecting.

Main method to modify "Surface with self-intersection" is the function
[Recalculate Surface] ( ); however, in this case, the error will be
modified by [Make Base-Surface Smaller].



In the error "Surface with self-intersection", it might be easier to see where
they intersect by checking the control points of the surface.
Surface control points are displayed by selecting [Analysis] > [Control
Points] > [Surface] ( ) and picking a face.

2. Press [Make Base-Surface Smaller] ( ) in Repair Tool on Navigation panel.

3. On "3D View" window, the reduced base surface is highlighted in light blue. A confirmation
dialog will appear. Click [OK].

Self-intersection is modified and the category list is updated.
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By reducing the base surface in this way, you can modify self-intersection without changing
the geometry of face. (before modification → after modification)

5.1.5. Modifying Acute Face Connection

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " FaceCusp.drfx_sx " in <tutorial> folder.

1. In [Main (Work)] panel, select "Acute face connection" from the category list. Target position
is highlighted in red on "3D View" window.

 Zoom into the target position and confirm the two faces (yellow and
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magenta) that are connected at an acute angle.

For this sample model, modify the error by deleting the invalid face
(yellow) that exists inside the solid.

The functions [Remove Faces With Fix] ( ) and [Change Face Boundary]
( ) can be used to modify. Here, use [Change Face Boundary] ( ) to
modify.


When using the function [Remove Faces With Fix] ( ), the yellow face is
deleted, and the magenta face boundary is automatically changed so that
there are no unused edges in the boundary with the deleted face.

2. Press [Change Face Boundary] ( ) in Repair Tool on Navigation panel.

3. Pick the magenta face on "3D View" window.

4. To change the boundary of the magenta face, pick two edges that will be the new boundary.
Press [Done] ( ).

5. A confirmation dialog will appear. Click [Yes}.
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6. A confirmation dialog will appear. Confirm that the new boundary edges are highlighted on
"3D View" window. Click [OK].

7. "Change Face Boundary" dialog will appear. Confirm that the face to keep (highlighted in
blue in "3D View" window) is set appropriately, and click [Keep selected face].

Face boundary is changed, and the category list is updated. Press [Quit (Esc)] ( ) to quit
the command.

8. In [Main (Work)] panel, select "Free edge" from the category list. The part where you
changed the boundary of the magenta face is highlighted in red.

9. Select [Edit] > [Delete] from the menu or click [Delete] ( ) on the toolbar.

10. On "3D View" window, pick the face where the boundary of the face has been changed, and
press [Done] ( ).
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The face is deleted. Press [Quit (Esc)] ( ) to quit the command.

11. Press [Stitch (pick)] ( ) in Repair Tool on Navigation panel.

12. Pick the edge highlighted in red on "3D View" window, and press [Done] ( ).

The edge is stitched and the category list is updated.
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Appendix A: Appendix

A.1. Error Items

Category Error Item Description Severit
y

Tiny
Element

Short Curve Detect a curve that is shorter than the
tolerance in length.

Critical

Sliver Face Detect a face with maximum width less than
the tolerance.

Critical

Tiny Step Free Edge Detect a step-like geometry with a tiny edge
that has been used once on the face.

Minor

Topology Edge Direction Detect an edge whose direction does not
match the direction flag of the belonging
loop.

Critical

Free Edge Detect an edge which is used by a face only
once.

Serious

Missing face Detect an edge loop which contains an edge
used by a face once.

Serious

Edge used more than
twice

Detect an edge that is shared by faces more
than twice.

Serious

Isolated Curve Detect a curve that do not have topological
relation with any faces.

Minor

Gap around
Vertex

Gap: Terminal Point of
Edges

Detect a gap between end points of edges
linked to the same vertex.

Serious

Gap: In loop Detect a gap between the edge endpoints in
the loop.

Serious

Gap: Edge and Vertex Detect a gap between a vertex and an
endpoint of the edge linked to that vertex.

Serious

Gap: Vertex and
Surface

Detect a gap between the vertex and the
related UV curve at the actual distance.

Serious

Gap
between
Edge and
Surface

Gap: Edge and Base
Surface

Detect a gap between the edge used on the
face and the base surface.

Serious

Gap: Edge and UV
Curve

Detect a gap between the edge used on the
face and UV curve.

Serious

Gap: 2D trimming
curve to 3D

Detect the actual gap of UV curve associated
with one edge.

Serious
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Category Error Item Description Severit
y

Invalid
Element

Surface with Singular
Point

Detect the surface where U and V directions
are parallel at the corner of the curved
surface and the normal line cannot be
calculated.

Serious

Edge crossing of
Surface Pole

Detect the edges of face passing through the
poles of the base surface.

Critical

Intersecting Loops Detect loops that intersect each other on the
same face.

Critical

Loop with Self-
Intersection

Detect a self-intersection loop. Serious

Surface with Self-
Intersection

Detect a self-intersecting surface. Critical

Continuity Cusp Curve Detect a curve with G1 discontinuity. Critical

Creased Surface Detect a surface with G1 discontinuity.
(Check the discontinuity for both u and v
directions.)

Critical

Quality Curve with Many
Segments

Detect curves with more than a certain
number of segments (control points).

Minor

Surface with Many
Patches

Detect surfaces with more than a certain
number of patches (control points).

Minor

Surface with Small
Patch

Detect small patches on a surface. Serious
(*1)

Curve with Short
Segment

Detect a curve with small segment. Serious

Aspect Ratio of Patch Detect a patch with high aspect ratio. Minor

Aspect Ratio of Surface Detect a surface with high aspect ratio. Minor

Curve with Oscillations Detect a curve whose control points form
oscillation.

Minor

Surface with
Oscillations

Detect a surface whose control points form
oscillation.

Minor
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Category Error Item Description Severit
y

Others Edge Interference Detect interference within tolerance
between edges which belong to the same
volume.

Serious

Duplicated Vertex Detect duplicated vertices which are located
closer to each other than the tolerance.

Serious

Acute Edge Connection Detect where the two edges connect at an
acute angle in the loop.

Minor

Acute Face Connection Detect where the adjacent face and the base
surface is connected at an acute angle in the
loop.

Minor

Duplicate Faces Detect whether a face completely overlaps
another face within the tolerance.

Minor

Shells interference in a
Part

Detect an intersection between two shells
belonging to the same part.

Minor

Explanation of Severity Level

The following section describes how error items for each severity affect data translation.

Critical

Serious problems may occur, such as data not being passed to the target CAD system.

Serious

When passing data to the target CAD system, some data may not be passed, or an error
may occur in the operation after being passed.

Minor

This is just a warning. This level hardly affects the data translation. However, it is
recommended to look through the errors because they may cause problems in the post
processes such as analyzing, manufacturing, etc.
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A.2. Analytic Surfaces
In addition to NURBS, which represents general surface, there are surfaces called "Analytical
surfaces," such as spheres and cylinders. Analytical surfaces have the following characteristics.

1. Relatively easy to change the geometry in post-process.
For example, the radius and the height of a cylinder can be changed quite easily.

2. Easy to process with CAM, etc.

3. The center of cylindrical or spherical surface can be determined accurately.



Please note that although analytical surfaces have such characteristics,
depending on the modification function, the surface may slightly deformed
after modification, ending up as a general surface. When passing analytical
surface for post processing, the appropriate modification function must be
used.

■ Relationships between modification functions and analytical surfaces
before and after modification

Function Name Surface Type

Project Edge on Surface ○

Extend Surface ○

Boundaries→Surface ×

Boundaries, Surface→Surface ×

Recalculate Surface ×

Fit Face to Loops ×

Divide Face ○

Approximate Surface ○*[1]

Make Base-Suface Smaller ○

Change Face Boundary ○

Surface Type

◯ : Kept
× : Change to General Surface

*[1] If it’s possible to approximate the surface as an analytical surface, the surface will be
replaced with an analytical one.
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