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1. Preface

1.1. About this Tutorial
This tutorial is composed of two parts: "3, Recognize and Remove Feature" and "4, Other
Simplification Functions". You can learn how to operate CADdoctor SX (Simplification mode)
step by step.


Simplification mode is a function that performs geometry simplification by
removing characteristic shapes such as fillets, holes, bosses, ribs, and
chamfers.

Furthermore, the features described in this tutorial are just a part of CADdoctor SX
(Simplification Mode). Please refer to the online help for other features.

About Help

For CADdoctor SX help, select [Help] > [Help Index] from CADdoctor SX menu. The help
provides details about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark appears next to the cursor so either click the menu or the icon.


Go through CADdoctor SX "Tutorial -Standard function-" to learn the basic
functions of CADdoctor SX before starting this tutorial.


CADdoctor SX FEM package is required to use CADdoctor SX (Simplification
Mode).
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] (  ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Simplification is not displayed in the CADdoctor SX, select
[View] > [Toolbar] > [Simplification].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\simplification"
inside the folder where CADdoctor SX is installed.



Please note that sample models are in drfx_sx format, and stores the
CADdoctor SX settings, so that CADdoctor SX will switch to Simplification Mode
automatically when opening those sample models. Switch to Simplification
Mode manually from the pull-down list in [Main (Work)] panel when
importing CAD models.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your CADdoctor SX depending on your specific computer hardware and CADdoctor SX version.
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2. Operation Flow
This tutorial will review the standard flow through the use of the simplification tools. As seen in
the table below, this process follows the standard CADdoctor SX sequence of operations with
new capabilities defined in steps 4, 5 and 6.

Operation Mode

1 File Import

Translation2 Model Check

3 Stitch (if free edges exist)

4 Recognize and Remove Feature
Simplification

5 Additional Simplification Functions

6 Auto Heal

Translation7 Manual Heal

8 Export File

The following will explain how to use Simplification mode (Steps 4～5 in the above flow) using
sample files. Please refer to the help if you see any unknown terms during the tutorial.
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3. Recognize and Remove Feature
This chapter explains the procedure to simplify the geometry by recognizing and removing
geometry features such as fillets, holes, bosses, and ribs. Most operations are automatic;
therefore Simplification can be done very easily.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " feature.drfx_sx " in <tutorial> folder.

3.1. Recognize and Remove Fillets
1. Select "Fillet" from the feature list to display [Check All Fillets] ( ) in [Main] panel. Press

this icon to automatically recognize fillets(*1).



[Check All Fillets] (*1)
Fillet recognition is based on the threshold value displayed in the list. (This
threshold can be changed by right-clicking "Fillet" and selecting "Modify
Threshold" from the context menu.)
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
You can also run [Check All Fillets] by double-clicking "Fillet" row in the
feature list.

The number of "Fillet" will be updated in the feature list, and the recognized fillets will be
highlighted in "3D View" window once the fillet recognition is completed.



In this tutorial, all fillets whose fillet radius is 5 mm or smaller will be
recognized as per the threshold. To recognize the large fillets of the model,
change the maximum limit of the threshold value, and perform automatic
recognition again.

Command(s) to remove Fillets will be listed in [Navigation] panel.

2. Press [Remove All (Fillets)] (  ) to remove recognized fillets.



Click [Check Options]( ) to customize the features to show in the category list.
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Check in the checkbox for the features in "Check Options" dialog > [Check
items] page to show them in the category list in [Main (Work)] panel.

3.2. Recognize and Remove Holes
1. Select "Round Hole" from the feature list to display [Check All Round Holes] ( ) in [Main]

panel. Press this icon to automatically recognize holes.

The number of recognized feature "Round Hole" is displayed, and the recognized areas are
highlighted.
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 In this case, holes with a diameter of 25 mm or less are recognized.

Command(s) to remove/extract Round Holes will be listed in [Navigation] panel.

2. Press [Remove All (Round Holes)] (  ) on Navigation panel to remove recognized holes.

Rotate the model in "3D View" window, and you will find semicircle holes as shown in the
image below. Such holes will not be recognized automatically, so mark and remove them
manually.
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3. Press [Check/Uncheck Round Hole] (  ) from [Main] panel.

4. For manual recognition, pick the face around the hole (In the figure, the face is highlighted
in blue) and press [Done](  ).

 To recognize a through hole, pick the faces on both sides of the hole.

5. A confirmation dialog will appear. To recognize the area as a round hole, click [Yes].
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The number of recognized feature "Round Hole" is displayed, and the recognized areas are
highlighted.

Command(s) to remove/extract Round Holes will be listed in [Navigation] panel.

6. Press [Remove All (Round Holes)] ( ) on Navigation panel to remove all recognized round
holes.
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3.3. Recognize and Remove Boss/Ribs
1. Select "Boss/Rib" from the feature list to display [Check All Bosses/Ribs] ( ) in [Main]

panel. Press this icon to automatically recognize Boss / Rib. (Double-click "Boss/Rib" from the
feature list to automatically recognize as well.)

The number of recognized feature "Boss/Rib" is displayed, and the recognized areas are
highlighted.



Boss/Rib recognition is performed based on the threshold value displayed
in the list. Please refer to the help for more details about setting the
threshold.

Command(s) to remove Bosses and Ribs will be listed in [Navigation] panel.
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2. Press [Remove All (Bosses/Ribs)] (  ) on Navigation panel to remove all recognized
bosses/ribs.

3.4. Recognize and Remove Projection
Shapes on the face such as bosses/ribs can also be recognized manually as projections. This
section will explain how to recognize bosses/ribs as projections and remove them.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " feature2.drfx_sx " in <tutorial> folder.

1. Select "Projection" from the feature list to display [Check/Uncheck Projection] ( ) in
[Main] panel. Press this icon. CADdoctor SX will be in a waiting state for you to pick the face.
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2. Pick the face around the projection (In the figure, the face is highlighted in blue.) and press
[Done] (  ). For this model, pick one of the faces highlighted in cyan below.

3. A confirmation dialog will appear. To recognize the area as a projection, click [Yes].

The number of recognized feature "Projection" is displayed, and the recognized areas are
highlighted.

 Mark other areas as Projection in the same procedure as required.
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Command(s) to remove Projections will be listed in [Navigation] panel.

Once you complete marking all projection areas manually, click [Quit (Esc)] ( ) to exit the
command.

4. Press [Remove All (Projections)] ( ) on Navigation panel to remove all recognized
projections.

3.5. Recognize and Extract Holes

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " hole.drfx_sx " in <tutorial> folder.

1. Select "Round Hole" from the feature list in [Main] panel, and press [Check/Uncheck Round
Hole] (  ).

CADdoctor SX Tutorial -Geometry Simplification-

 © 2024 Elysium Page 13 | 25



2. To recognize a through hole, pick the faces on both sides of the hole, and press [Done] ( 
).

3. A confirmation dialog will appear. Click [Yes] to recognize the area as a round hole. (The
image below is showing the result in Semi-transparent mode for better visibility.)

Command(s) to remove/extract Round Holes will be listed in [Navigation] panel.

4. Press [Extract All Round Holes] (  ) to extract only the recognized holes as another solid
part.
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3.6. Recognize and Remove Steps

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " remove_step.drfx_sx " in <tutorial> folder.

In this tutorial, set the following option for step ([Simplification] > [Options]). Please refer
to the help for details about the settings.

1. Select "Step" from the feature list in [Main] panel, and click [Check All Steps]( ) to
recognize Steps automatically.
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The number of recognized feature "Step" is displayed, and the recognized areas are
highlighted.

Command(s) to remove/extract Steps will be listed in [Navigation] panel.

2. Click [Remove All (Steps)]( ) in [Navigation] panel to remove all Steps.

After the automatic removal, you will still find a step on the model as shown in the image
below. The maximum height of this step is greater than the threshold and will not be
recognized automatically, so mark and remove it manually.
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3. Press [Check/Uncheck Step] (  ) in [Main] panel.

4. Pick the face to be recognized as step, and press [Done] (  ).

5. A confirmation dialog will appear. Click [Yes] to recognize the area as the step if you prefer.

6. Press [Remove Step] (  ) on Navigation panel to remove the recognized step.

CADdoctor SX Tutorial -Geometry Simplification-

 © 2024 Elysium Page 17 | 25



7. Select a face in "3D View" window to specify the resulting height after removing the step.

The step will be removed to make a flat face on the specified height.

Rotate the model in "3D View" window, and you will find another step on the other side of
the model as shown in the image below. This step is higher than the threshold and will not
be recognized automatically, so mark and remove it manually.

8. Press [Check/Uncheck Step] (  ) in [Main] panel.
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9. Pick the face to be recognized as step, and press [Done] (  ).

10. A confirmation dialog will appear. Click [Yes] to recognize the area as the step if you prefer.

11. Press [Remove Step] (  ) on Navigation panel to remove the recognized step.

12. Select a face in "3D View" window to specify the resulting height after removing the step.
The result will differ depending on it.

■ Blending to the higher side
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■ Blending to the lower side
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4. Other Simplification Functions
This chapter explains the procedure to manually simplify the geometry on the areas which
cannot be simplified by feature (Fillets, Holes, Bosses, Ribs, etc.) removal.

4.1. Fill Crack (Create surface between curve sets)
The command [Fill Crack] creates a new connecting face between the two specified edges.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " others.drfx_sx " in <tutorial> folder.

1. Select [Simplification] > [Fill Crack] from the menu, or click [Fill Crack]( ) in the toolbar.

2. Select free edges on the side to connect from.

Click [Yes] in the confirmation dialog to use the selected free edges.
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3. Select free edges on the side to connect to.

Click [Yes] in the confirmation dialog to use the selected free edges.

Face(s) which connect the selected free edges will be created.

4.2. Remove Faces with Fix
This section explains the procedure to simplify the geometry by deleting the selected faces, and
then re-constructing that area by extending the adjacent faces, etc.

1. In this example, select [Simplification] > [Remove Faces with Fix] ( ).

2. Select two faces to delete in "3D View" window, and click [Done] ( ).
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The selected faces will be deleted, and that area will be re-constructed referencing the
adjacent faces.

Repeat this step for the other side if desired as below.

CADdoctor SX Tutorial -Geometry Simplification-

 © 2024 Elysium Page 23 | 25



4.3. Merge Faces
This section explains the procedure to simplify the geometry by auto-detecting mergeable faces
in the model, and then merging those faces.

1. Select "Mergeable Faces" in the feature list, and click [Check All Mergeable Faces] ( ) in
[Main (Work)] panel.

The number of recognized feature "Mergeable Faces" is displayed, and the recognized areas
are highlighted.

Command(s) to merge detected Mergeable Faces will be listed in [Navigation] panel.

2. Press [Merge All Mergeable Faces] ( ) on Navigation panel to connect (merge) the
recognized connectable faces.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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