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1. Preface

1.1. About this Tutorial
This tutorial is composed of two parts which are "3, Polygon PDQ" and "4, Generate Polygons
from Point Cloud" and you can learn how to operate CADdoctor SX (Polygon PDQ Mode) step by
step.

■ Polygon PDQ Mode

This mode allows you to check the quality of polygons (STL data) and heal them. Polygon
smoothing is also possible.

■ Polygon PDQ (Point Cloud to Polygon)

With this function, you can create polygons from the point cloud data. It is possible to
remove noise included in the point cloud as well.

Furthermore, the features described in this tutorial are just a part of CADdoctor SX (Polygon
Check/Healing). Please refer to the help for additional information.

About Help

For CADdoctor SX help, select [Help] > [Help Index] from CADdoctor SX menu. The help
provides details about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of offline help, select [Help] > [Context
Help], and a question mark appears next to the cursor so either double-click the menu or
just click the icon.


Go through CADdoctor SX "Tutorial -Standard function-" to learn the basic
functions of CADdoctor SX before starting this tutorial.


CADdoctor SX FEM package is required to use CADdoctor SX (Polygon PDQ
Mode).
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1.2. About the Notations of Menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] (  ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of polygon Check/Healing is not displayed in the CADdoctor SX,
select [View] > [Toolbar] > [Polygon PDQ].

1.3. About Sample Data
The sample data to be used is located in the folder "\document\tutorial_models\polygon" inside
the folder where CADdoctor SX is installed.

1.4. About Images
The images in this document may include slight differences from the ones actually displayed on
your CADdoctor SX depending on your specific computer hardware and CADdoctor SX version.
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2. Operation Flow
This tutorial will explain about the standard procedure in using the polygon Check/Healing
function. As seen in the table below,

this process follows the standard CADdoctor SX sequence of operations with new capabilities
described in steps 2 through 5 in Polygon PDQ mode.
*Red text indicates operations to be performed in Polygon PDQ mode.

Operation Mode

1 File Import

Polygon PDQ

2 Check polygon

3 Auto Heal for Polygon

4 Smoothing Polygon

5 Manual Heal for Polygon

6 File Export

In the following chapters, operation procedures for Polygon PDQ mode (Step 2-5 shown above)
will be explained by using the samples files. Please refer to the help for further information of
the operations used in this tutorial.
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3. Polygon PDQ
This section illustrates the example procedure for Polygon PDQ of CADdoctor SX.

3.1. Import STL File as a Polygon Data
Import the sample model (sample_polygon1.STL) into CADdoctor SX.

1. Select [File] > [Import] from the menu or click [Import] ( ) on the toolbar.

2. "Open" dialog will appear. Switch the file type to "STL (*.stl)".

Specify " sample_polygon1.STL " from the <tutorial> folder, and click [Option].

3. "Option" dialog will appear.
Confirm that the settings are the same as shown below and click [OK].
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4. Click [Open] in "Open" dialog to import polygon data.



If the mode is not in "Polygon PDQ", change it to "Polygon PDQ" mode in
[Main (Work)] panel.
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Toggle Display Type (Polygon)

• Display type of polygon data can be switched by [Display type (Polygon)] (  ) on
the toolbar.

◦ [Wireframe (Polygon)] ( ): Polygon is displayed by wireframe mode.

◦ [Shading (Polygon)] ( ): Polygon is displayed in shading mode.

◦ [Shading + Wireframe (Polygon)] ( ): Display polygons in shading and
wireframe.

◦ [Semi Transparent (Polygon)] ( ): Display polygons in a semi-transparent shaded
view.
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• You can change the face color of polygon in [File] > [Display Preference] > [Display
Attribute] page > "Polygon Color".

3.2. Check Errors in Polygon Data
Run check on polygon data.

1. Confirm the category list on [Main (Work)] panel. Check results are shown because auto-
check ran when the polygon was imported.



If the result is not displayed, press [Check] (  ) in [Main (Work)] panel.

In "Import / Export Settings" dialog, because "Execute" is enabled by default
in the option "PDQ" of [Import Common] page, check runs automatically
during import.

CADdoctor SX Tutorial -Polygon Check/Healing-

 © 2024 Elysium Page 7 | 22



2. Specify "Sliver Triangle" from the category list in [Main (Work)] panel, and then press [Zoom
current target] ( ).

Current error location is zoomed in on "3D View" window.

3. Press [Display Surrounding] (  ) to display on "3D View" window not only the polygon
containing the sliver triangle, but also the surrounding polygons. Also, next to [Display
Surrounding] (  ), the icons [Extend Display Region] (  ) and [Reduce Display Region] (

 ) will appear.
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By using [Extend Display Region] and [Reduce Display Region] icons, you can change the
display region of the polygons detected by the "Sliver Triangle".

3.3. Heal Polygon Data Automatically
Auto heal the polygon data.

1. Select [Polygon PDQ] > [Options] to display "Polygon PDQ option" dialog.

2. Select [Polygon Auto-Heal] page in "Polygon PDQ option" dialog. Enable the options "Modify
Free Edge" and "Modify Short Edge", and click [OK].

3. Press [Auto Heal] (  ) in [Main (Work)] panel to heal "Free Edge" and "Short Edge".
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

If several errors are remaining after auto healing, you can also perform
interactive healing on the Work Tab.

One free edge remains in this case, but it is not an error that needs to be
healed because it is on the outer edge of the polygon face.

3.4. Smoothing Polygon
Smooth the polygon data.

1. Select [Polygon PDQ] > [Polygon Smoothing] > [All] or select [Polygon Smoothing] (  ) on
the toolbar.

All polygons become smooth.

Next, smooth the specified region of polygon data.
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2. Select [Polygon PDQ] > [Polygon Smoothing] > [Specified Region] from the menu or select
[Specified Region] (  ).

3. As shown in the below figure, pick from point 1 to point 5 in sequence, and press [Done]
(  ). Specified region of polygon data will be smooth.

3.5. Manual Healing for Polygon Data
Manually heal the polygon data. There are two ways of manual healing.

• Change the check items' threshold and heal the errors

• Delete polygon and fill hole

3.5.1. Change the check items' threshold and heal the errors

Perform healing after changing the threshold for "Long Edge" in the category list.

1. Select "Long Edge" in the check item and right-click. Select [Modify Threshold] as follows.

2. "Long Edge" dialog will appear. Change the threshold as pictured below (0.5 mm) and click
[OK].

3. Press [Check] (  ) in [Main (Work)] panel to detect "Long Edge".
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
Please note that the process to smoothen the polygon models may affect the
result of "Long Edge" detection.

4. Select [Polygon PDQ] > [Repair Errors] > [Repair All Long Edges] from the menu or click
[Repair All Long Edges] ( ) on Navigation panel. Long Edge will be healed by using
"Repair All Long Edges".

The area with the error "Long Edge" has been healed.

5. Similarly, select "Short Edge" from the category list, and then select [Repair All Short Edge] (
 ) on Navigation panel.

All critical errors have been healed.
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3.5.2. Delete polygon and fill hole

Delete unnecessary polygon and fill hole. This is useful in case you are dealing with rugged
polygon.

1. Select [Polygon PDQ] > [Fill Hole] > [Remove Triangles with Fix] (  ).

2. Pick points on "3D View" window to enclose the area you want to heal, and press [Done]
( ).

Polygons within the selected area will be healed.
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3.6. Export STL File after Healing the Polygon Data
Export the healed polygon data as STL file.

1. Select [File] > [Export] or click [Export] ( ) on the toolbar.

2. "Save As" dialog will appear. Switch the file type to "STL (*.stl)". Enter the file name and the
location to save the file, and then click [Save].
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4. Generate Polygons from Point Cloud
This section illustrates the example procedure to create Polygon from Point Cloud.

4.1. Import Point Cloud Data from .txt File
Import the TXT format sample model (sample_PointCloud.txt) into CADdoctor SX.

1. Select [File] > [Import] or [Import] ( ) from the toolbar.

2. "Open" dialog will appear. Switch the file type to "Point Cloud (*.txt, *.asc, *.xyz)".

Specify " sample_PointCloud.txt " from <tutorial> folder, and then click [Option].

3. "Option" dialog will appear.
Confirm that the settings are the same as shown below and click [OK].
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4. Click [Open] in "Open" dialog to import the point cloud data.



If the mode is not in "Polygon PDQ", change it to "Polygon PDQ" mode in
[Main (Work)] panel.
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Display setting of Point Cloud

The displayed point cloud density on "3D View" window can be adjusted in [File] >
[Display Preference] > [Tessellation Tol] page.

■ Density differences between 1.33 (units/ pixel) and 0.2 (units/ pixel)
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4.2. Remove Outliers in Point Cloud Data
This function automatically removes outliers (e.g., points with incorrect coordinates) contained
in the scanned point cloud.

1. Select [Point Cloud] > [Remove outliers] or select [Remove Outliers] (  ) on the toolbar.

2. Change "Threshold number of points" to 45, and click [Detect].


In this case, the outliers of point cloud data can all be removed by setting
"Threshold number of points" to 45.

Outliers will be detected, and the number of detected points will be displayed in "Remove
Outliers" dialog.

In addition, the outliers will be highlighted in red on "3D View" window.

3. Click [Remove] to remove outliers.
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Point clouds detected as outliers are removed.

4.3. Create Polygon from Point Cloud Data
Create polygon data from the point cloud from which outliers were removed in the previous
step.

1. Click [Generate Polygons from Point Cloud] (  ) in [Main (Work)] panel.


It is possible to run from [Point Cloud] > [Generate Polygons from Point
Cloud] in the menu or [Generate Polygons from Point Cloud] (  ) in the
point cloud toolbar.

2. "Generate Polygons from Point Cloud" dialog will appear. In this case, leave the settings as is
and click [OK].

Polygon data can be created from point cloud data.

* The following image hides the point cloud and shows only the polygon.
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

Twin View (Reverse Engineering) toolbar allows you to view the point
cloud and polygon side by side.

In "Point Cloud option" dialog from [Point Cloud] > [Options], you can
adjust the Mesh fineness and Trimming area of the polygons.
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4.4. Verification of Distance between Polygon and
Point Cloud
Verify the distance between the created polygon data and point cloud data.

1. Select [Analysis] > [Show Distance] > [Options] or click [Set show difference options] ( )
from the toolbar.

2. "Show difference option" dialog will appear. In this case, disable "Auto" in the range, and
change "Maximum" to 0.02mm, and "Minimum" to -0.02mm. Then click [OK].

3. Select [Analysis] > [Show Distance] > [Point Cloud - Polygon] or click [Show Distance
between Point Cloud and Polygon] (  ) from the toolbar.

It is possible to check the errors between the point group and the polygon on "3D View"
window.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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