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1. Preface

1.1. About this Tutorial
This tutorial consists of four chapters explaining about "3, Data Size Reduction" and "4, Solid
Enveloping" in [Envelop Solid] mode of CADdoctor SX.

■ Data size reduction

Create a reduced size model from an assembly model.

■ Solid enveloping

Extract the boundary of the assembly model as a one part solid.

This tutorial covers part of the [Envelop Solid] mode of CADdoctor SX. Please refer to the help
for other functions.

About Help

For CADdoctor SX help, select [Help] > [Help Index] from CADdoctor SX menu. The help
provides details about the content, how to operate, options, and things to keep in mind.

Another way to open the corresponding page of help, select [Help] > [Context Help], and a
question mark will appear next to the cursor so either click the menu or the icon.


Go through CADdoctor SX "Tutorial -Standard function-" to learn the basic
functions of CADdoctor SX before starting this tutorial.

 CADdoctor SX FEM package is required to use CADdoctor SX envelop solid.
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1.2. About the notations of menus and Icons
Each menu item button or dialog is represented by [Menu Name] and icon image. Right angle
bracket (>) is used in sub menu.

For example:
The function of fit is described as [View] > [Fit] (  ).

In this tutorial, the folder containing sample data is referred to as <tutorial>.


If the toolbar of Envelop is not displayed in the CADdoctor SX, select [View] >
[Toolbar] > [Envelop].

1.3. About sample data
The sample data to be used is located in the folder "\document\tutorial_models\envelop" inside
the folder where CADdoctor SX is installed.

1.4. About images
The images in this document may include slight differences from the ones actually displayed on
your CADdoctor SX depending upon your specific computer hardware and CADdoctor SX
version.
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2. Operation Flow
This tutorial will explain the standard operations when using the Envelop Solid functions. The
overall procedure is as follows.

As you can see in the table below, this process follows the standard CADdoctor SX sequence of
operations with new capabilities defined in steps 4, 5 and 6.

Operation Mode

1 File Import

Translation2 Model Check

3 Stitch (if free edges exist)

4 Feature Recognition and Removal
Simplification

5 Additional Simplification

6 Data Size Reduction Solid Enveloping Envelop Solid

7 Auto Heal

Translation8 Manual Heal

9 Export File

The below section explains about the operation in the [Envelop Solid] mode (step 6) using
sample models. Please refer to the help if you see any unfamiliar terms during the tutorial.



Please note that you need to switch to [Envelop Solid] mode to use the function.
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3. Data Size Reduction
With Data Size Reduction functionality in Envelop Solid mode, you can create a lightweight
model from an assembly model "per face" or "per volume".

3.1. Data Size Reduction in Face Units
Extract visible faces in face units and create a lightweight sheet model.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " extract.drfx_sx " in <tutorial> folder.

Select [Envelop Solid] > [Options] from the menu. Specify "Data size reduction" in
[Common] tab from "Envelop option" dialog, and click [OK].

1. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] icon
( ) in [Main] panel.
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2. "How to Reduce the Data Size" dialog will appear. Select "By extracting visible faces only
(Result in sheet model)" and click [Next].

3. The "Extract Visible Face" dialog will appear. Select "6 directions" for basic directions in
"Define View Directions".

Basic direction axes (XYZ axes) will appear in "3D View" window.


If the basic direction axes do not appear on "3D View" window, select "6
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directions" radio button again.

4. Remove unnecessary view direction(s).
In "Extract Visible Face" dialog, click [Remove] in "Edit view directions".

5. In this tutorial, we use the X plus direction as the view direction. So, select all the other
directions in "3D View" window to delete them. The selected axis changes its color from
magenta to purple.

 Use [Area Selection Mode] ( ) in Smart Filter to select multiple axes.

6. Press [Done] ( ) to remove the picked axis.

7. In this case, to check the face to be extracted from the X axis direction, select "Add a face
attribute" and click [Execute].
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

In "Extract Visible Face" dialog, specify the behavior after extraction from
the below three options in "How to Treat Invisible Faces".

◦ Hide all invisible faces: Hide faces that are not going to be extracted.

◦ Delete all invisible faces: Delete faces that are not going to be
extracted.

◦ Add a face attribute: Add "Unextracted face" attribute to the faces that
are not going to be extracted.

Only faces that are visible from the X axis direction are extracted, and invisible faces
(unextracted faces) are marked pink and "Unextracted face" attribute added.


Depending on the environment, the result of "Extract Visible Face" may
differ.


For the face with an unextracted face attribute, perform "Set/Unset
Attribute", "Hide All Unextracted Faces", and "Remove all Unextracted
Faces" from [Extract Solid] > [Extract Visible Faces].

In this case, use the function below to manually change the unextracted faces as an extraction
target and remove the unextracted face.

8. Select [Envelop Solid] > [Extract Visible Faces] > [Set/Unset Attribute] and pick a face without
the unextracted face attribute. Unextracted face attribute is added to the picked face.
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9. On "3D View" window, pick a face without an unextracted face attribute, and then press
[Done] ( ). Unextracted face attribute is added to the picked face.

10. Pick a face with unextracted face attribute and press [Done] ( ). The unextracted face
attribute is removed.

11. Press [Cancel] ( ) when you are done adding or removing the unextracted face attribute.



Please note that if you select a face with unextracted attribute and an
unspecified face at the same time, the following dialog will appear.
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12. Select [Envelop Solid] > [Extract Visible Faces] > [Remove All Unextracted Faces] to remove
faces with unextracted face attributes.

Faces with unextracted face attributes are removed.
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3.2. Data Size Reduction in Volume Units
This section explains the capability to simplify the model by deleting invisible volumes,
removing features(*), or replacing with simple shapes per volume, and then create a lightweight
model that results in a solid model.


(*) The features covered here are "Invisible Volumes," "Small Volumes," "Small
Parts," and "Holes/Grooves/Protrusions".

3.2.1. Run Data Size Reduction (Delete Each Feature)

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " envelop.drfx_sx " from <tutorial> folder.

Select [Envelop Solid] > [Options] from the menu. Make sure you have the following
settings set in [Common] tab of "Envelop option" dialog.

• Purpose: Data size reduction

• Target: "Only visible elements" is enabled


Please note that when enabling "Only visible elements" option, only the
elements displayed on "3D View" window are targeted for Solid
enveloping.
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Toggle the display on "3D View" window (per part)

When you want to show/hide the CAD model in "3D View" window for each part, using
the command [Show/No-Show Parts] is useful.

Select [View] > [Show Elements] > [Show/No-Show Parts] from the menu or select
[Show/No-Show Parts] ( ) on the toolbar. "Show/No-Show Parts" dialog will appear.

Enter the condition in the filter box, and the part(s) that meet those condition will be
highlighted in green and listed at the top of the list.

Select part(s) in the list, and the corresponding parts will be highlighted in blue in "3D
View" window. Also, select a part on "3D View" window, and the corresponding part will
be highlighted in blue in the list.

 Select while pressing down [Ctrl] key or [Shift] key to multi-select.
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

Either enable the checkbox at the left end of the list or select an item in
the list to activate the Show/Hide button. Click [Show] / [No Show] to
change the show/hide status of the parts.

1. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] ( )
in [Main] panel.

2. "How to Reduce the Data Size" dialog will appear. Select "By simplifying the geometry
(Result in solid model)" and click [Next].

3. The following dialog will appear. Enable "Delete Invisible Volumes", "Delete Small Volumes",
"Delete Small Parts", and "Remove All Holes/Grooves/Protrusions" and click [Execute].
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Invisible Volumes, Small Volumes, Small Parts, Holes/Grooves/Protrusions, etc. specified in
the dialog are removed. (Bottom left: Shading, bottom right: Semi Transparent)

In the [Main] panel, you can see that the part information is maintained.

CADdoctor SX Tutorial -Envelop Solid-

 © 2024 Elysium Page 13 | 55



3.2.2. Run Data Size Reduction (Replace Volume with Simple Shape)

This section explains the procedure to replace volumes with simple shape(s).

Preparation

The operation up to the middle is the same as 3.2.1, “Run Data Size Reduction (Delete Each
Feature)”.

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " envelop.drfx_sx " in <tutorial> folder.

1. Select [Envelop Solid] > [Reduce Data Size] from the menu or select [Reduce Data Size] ( )
in [Main] panel.

2. The "How to Reduce the Data Size" dialog will appear. Select "By simplifying the geometry
(Result in solid model)" and click [Next].
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3. The "Data Size Reduction" dialog will appear.
Uncheck [Enable] for "Delete Invisible Volumes", "Delete Small Volumes", "Delete Small
Parts", and "Remove All Holes/Grooves/Protrusions" if checked.

Check [Enable] for "Replace Volume with Simple Shape".
Check "Cuboid", "Cylinder", "Extruded shape" for "Replace with either" and select "No
restriction (Target all)" for "Restrict by size".

4. Click [Execute] after the settings. A lightweight model with replaced simple shapes is
created.

5. In the "display" toolbar, switch the display of CAD model in "3D View" window to "Semi
Transparent" ( ).
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Since it was executed without removing "Invisible Volumes", "Small Volumes", "Small Parts",
and "All Holes/Grooves/Protrusions", you can check to see that the internal geometry
remains.

Check structure tree in [Main] panel to confirm that part structure is maintained.
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Rules for "Replace Volume with Simple Shape"

Selected volumes will be replaced as follows:

• By cylinder when seen as a circle-shape from a certain angle. By tube when seen as a
circle-shape from a certain angle, and has a concentric through hole

◦ Cylinder

◦ Tube

• By extruded shape when seen as a rectangle from certain two angles

◦ Extruded shape

• By cuboid which is the same size as the bounding box of the original volume if none of
the above

◦ Cuboid
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4. Solid Enveloping
This chapter explains how to create a single-volume solid model from a multi-volume assembly
model with Solid Enveloping function.

You can use Solid Enveloping function more effectively by running geometry simplification
(removing geometry features, etc.) beforehand.

4.1. Preprocess for Enveloping: Feature Recognition
Prior to enveloping, use "Feature Recognition" function to recognize all the features inside the
assembly models and delete recognized features automatically.

In this section, "Round Hole" and "Generic Hole" will be used as examples.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
select " envelop.drfx_sx " in <tutorial> folder.

Select [Envelop Solid] > [Options] from the menu. In "Envelop option" dialog, select "Solid
enveloping" in [Common] page, and then click [OK].
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

Please note that you need to switch to [Envelop Solid] mode to use the
function.

4.1.1. Recognize Round Holes

1. Select "Round Hole" from the category list to display [Check All Round Holes] ( ) in [Main]
panel. Press this icon to automatically recognize holes.



Fillet recognition is based on the threshold value displayed in the list. (This
threshold can be changed by right-clicking "Fillet" and selecting "Modify
Threshold" from the context menu.)


You can also run the automatic feature recognition by double-clicking each
feature in the category.

The number of recognized feature "Round Hole" is displayed, and the recognized areas are
highlighted.
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4.1.2. Recognize Generic Holes

1. Select "Generic Hole" from the category list of [Main (Work)] panel, and [Check All Generic
Holes] (  ) will appear below the [Main] panel. Press this icon to automatically recognize
holes.

Once the automatic recognition is completed, the number of recognized generic holes will
be shown, and the areas recognized as generic holes will be highlighted in green in "3D
View" window.

2. If not automatically recognized, press [Check/Uncheck Generic Hole] ( ) to pick the faces
around the hole you want to recognize.

3. Select a face around the generic hole, and click [Done] ( ). For this model, select one of the
faces highlighted in cyan in the image below.
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4. A confirmation dialog will appear. Enable "Apply to all places" option, and click [Yes].

The number of recognized feature "Round Hole" is updated in the category list, and the
recognized areas are highlighted in green on "3D View" window. (The figure in the lower
right is temporarily switched to semi-transparent display.)


Change the view settings from [View] > [Display type] > [Semi Transparent]
in the menu or click [Semi Transparent] ( ) on the toolbar to see the
model before and after enveloping clearly.
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4.2. Enveloping
After recognizing "Round Hole" and "Generic Hole" through the above steps, the model should
look like below (recognized features are highlighted). Run envelop extraction to this model.

1. Select [Envelop Solid] > [Extract Envelop Solid] from the menu or press [Extract Envelop
Solid] ( ) on [Main (Work)] panel.

2. A dialog will appear. In this case, click [Continue] to apply the default settings.


Check "Fill gaps while enveloping" and specify the threshold (minimum
and maximum values) in the dialog if you would like to fill the gaps.

A single solid model will be created while deleting all the recognized features.
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Confirm that the assembly model has become a single solid model in [Main (Structure)]
panel.



Please note that CADdoctor SX may fail to create a single solid volume
depending on the original geometry.

In that case, it is often effective to fill the gaps between volumes before
and/or after enveloping.

Please refer to 4.4, “Fill Gap” for details.

How CADdoctor SX Extracts an Envelop Solid

■ When none of the interior parts can been seen from outside
⇒ Deletes all the interior parts. (Interior parts will be filled automatically.)

CADdoctor SX Tutorial -Envelop Solid-

 © 2024 Elysium Page 23 | 55



■ When there are some interior parts which can be seen from outside
⇒ The parts which can be seen from outside will remain.

4.3. Void with Openings
This section will explain the function of CADdoctor SX Envelop Solid by taking a case of
enveloping without any preprocess prior to enveloping as an example.

■ Executing Envelope Solid without feature recognition

In the images above, there are some interior parts remaining even after enveloping. This
happens because CADdoctor SX does not delete the interior parts when they have connection
with exterior parts (can be seen from outside).

If a geometry still remains inside, after executing envelop solid, recognize and delete "void with
opening".

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
open " envelop.drfx_sx " in <tutorial> folder.
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Select [Envelop Solid] > [Options] from the menu. In "Envelop option" dialog, select "Solid
enveloping" in [Common] page, and then click [OK].

4.3.1. Execute Envelop Solid without Feature Recognition

1. Select [Envelop Solid] > [Extract Envelop Solid] from the menu, or click [Extract Envelop
Solid] ( ) on [Main (Work)] panel.

2. A dialog will appear. This time, click [Continue] to run to solid enveloping with the default
settings.

CADdoctor SX Tutorial -Envelop Solid-

 © 2024 Elysium Page 25 | 55




We run solid enveloping without running the feature (e.g., round holes)
removal as a pre-process because it makes no difference with this sample.

Envelope Solid is executed. Because the feature is not recognized, a geometry (void) remains
inside.

4.3.2. Recognize and Delete Voids with Openings

This section will explain how to delete inner voids with openings which remains even after
enveloping.

1. When selecting "Void with Opening" from the category list of [Main (Work)] panel, [Check
All (Void with Opening)] ( ) icon will appear below the [Main] panel. Press this icon to
automatically recognize holes.

When automatic recognition is completed, the number of recognized voids with opening is
displayed. Also, the recognized voids with opening are highlighted in pink on "3D View"
window.


In case "Void with Opening" is not displayed in the category list, add it
according to the following procedure, and then run the feature recognition.
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1. Press [Check Options] ( ) located above [Main (Work)] panel.

2. "Check Options" dialog will appear so switch to [Check items] tab.

3. Set the category filter to "All" and enable "Void with Opening" at the
bottom of the list, and click [OK]. "Void with Opening" will appear in the
category list.

Command(s) to extract/remove Openings will be listed in [Navigation] panel.

2. Press [Fill All (Void with Opening)] ( ) in Navigation panel to delete all the recognized
voids with openings.



On the model on which Void with Openings error(s) are detected, set a Void
with Openings error to Current, and click [Extract Faces of Selected Void
with Openings] ( ) in [Navigation] panel to extract faces used for Current
error.

This is useful when you wish to fix the error (Void with Openings) while
maintaining the intended outline using editing tools.

■ Recognized Void with Opening and faces extracted from the recognized
void

CADdoctor SX Tutorial -Envelop Solid-

 © 2024 Elysium Page 27 | 55



The face extracted with [Extract Faces of Selected Void with Openings] ( )
will appear as "FaceOfVoidWithOpening" in the structure tree.
To show only the extracted face, right-click on "FaceOfVoidWithOpening" in
the structure tree and select "Exclusive Show" from the context menu.

4.4. Fill Gap
Gaps recognized when enveloping can be filled automatically, but depending on the shape, the
gaps may not be filled automatically. This section will explain how to manually fill gaps which
still remain after automatic deletion in enveloping.

4.4.1. Recognize and Delete Gap

Recognized gaps are filled automatically with cylinders or cuboids.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
select " envelop02.drfx_sx " in <tutorial> folder.
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1. Right-click "Gap" in the category list and select [Modify Threshold] from the context menu to
change threshold for gap recognition.


If "Gap" does not appear in the category list, press [Check Options] ( ) to
open "Check Options" dialog. Enable "Gap" from [Check items] page.

2. "Gap" dialog will appear. Set the range of gap as "0.1 mm" for minimum and "2 mm" for
maximum, and then click [OK].

3. Press [Check All Gaps] ( ) displayed below [Main (Work)] panel.

When automatic recognition is completed, the number of recognized gaps is displayed. Also,
the areas recognized as gaps are highlighted on "3D View" window.

Navigation panel will display icons for filling gaps and extracting faces around gaps.
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4. Press [Fill All Gaps] ( ) in Navigation panel. The recognized gaps are filled, and the
number of recognized "Gap" in the category list becomes "0".

5. Select [Envelop Solid] > [Extract Envelop Solid] from the menu or press [Extract Envelop
Solid] ( ) in [Main] panel to extract a model as a single solid.

■ Before and After Executing Envelop Solid (Structure tree)



As an alternative method, you can click [Fill Gap by Primitive] ( ) to
create new cuboid or cylinder which fills the gap automatically. This
method might be useful in a situation where [Fill All Gaps] ( ) or [Fill
Gap] ( ) does not work well.
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Use this method when some extent of deformation is allowed as long as
gaps are filled.

4.4.2. Create Primitive and Merge

[Create Primitive] function allows you to create a volume that fills in the gap by choosing which
geometry (cuboid or cylinder) to fill the gap with and where to create it.
In this case, create a cylindrical volume to fill the gap using the function [Create Primitive].

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
reopen " envelop02.drfx_sx " from <tutorial> folder.

1. Select [Envelop Solid] > [Create Primitive].

2. Select "Cylinder (By using existing arc or cylinder)" in "Option" dialog.
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
When creating a cylinder with [Create Primitive], a cylinder is created
based on the specified existing arc or the center of the cylinder and the
radius. In this case, specify an arc to create a cylinder.

3. Pick a reference arc for the primitive you want to create in "3D View" window.



Switch [Pick Filter] to [Edge] to pick the arc easily.

Pick a point on the bottom face under the existing cylinder to specify the height of the
primitive.

New primitive is created as in the below right.
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4. Move the viewpoint and pick the arc at the bottom of the geometry as the reference for the
primitive you want to create.

Similar to the previous procedure, pick a point on the top face to specify the height of
primitive.

New primitive is created as in the below right.

■ After executing Create Primitive (Left: Show all; Right: Show only cylinder)
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5. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes.

All volumes can be merged into one solid.

4.4.3. Create Primitive and Move

If the volume created with the function [Create Primitive] or the automatically created volume
to fill the recognized gap are misaligned, you can adjust the position with [Move] function.

This section will explain how to move primitives when there are misalignment between those
primitives and surrounding geometries.

Preparation

Select [File] > [Open] from the menu or click [Open] ( ) on the toolbar. In "Open" dialog,
select " gap.drfx_sx " from <tutorial> folder.

1. Make sure that the threshold of "Gap" in the category list of [Main (Work)] panel is set as 0.1
mm to 7 mm. Click [Check All Gaps] (  ). One "Gap" is recognized.
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When automatic recognition is completed, the number of recognized gaps is displayed. Also,
the areas recognized as gaps are highlighted on "3D View" window.

Navigation panel will display icons for filling gaps and extracting faces around gaps.

2. Press [Fill Gap by Primitive] ( ) in Navigation panel to automatically create a filling
primitive. (This time, a rectangular cuboid.)



The position of the created primitive is slightly diagonal in relation to the
original shape, so the corners will not match.
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Next, adjust the angle and position of the primitive (cuboid) to be aligned with the largest
face of the original geometry as shown in the upper right figure.

3. Select [Envelop Solid] > [Move Volume] > [Align by Axis] from the menu.

4. Pick the primitive (cuboid) to be moved.

5. Pick the edge (* Light blue edge in the lower left figure) of the primitive (cuboid) you want
to move. Next, pick the edge (* Light blue edge in the lower right figure) of the existing
geometry you want to align.
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

■ When displaying only the existing geometry (Below right figure)

Misalignment in Z axis direction is now fixed.

6. Press [Quit (Esc)] ( ) to exit [Adjust 2 Axes] command.
Next, fix the misalignment in Y axis direction and the angle by parallel shift and rotation.

7. Select [Envelop Solid] > [Move Volume] > [Align by 2 Axes] from the menu.

8. Select a primitive (cuboid) to move.
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9. Select an edge on the primitive (cuboid) (Ref: Left image), and an edge on the model (Ref:
Right image). These edges will be used as the primary axis.

10. Select an edge on the primitive (cuboid) (Ref: Left image), and an edge on the model (Ref:
Right image). These edges will be used as the auxiliary axis.


The primitive (cuboid) will be moved as to align two primary axes to be co-
axial, and two auxiliary axes to lie on the same plane.

Direction and angle of the primitive (cuboid) are now aligned.
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Finally, merge the volumes and merge the face groups.

11. Select [Envelop Solid] > [Merge Volumes] > [Merge All].

All volumes are merged into a single solid model.

12. Press [Face Merge] ( ) on Navigation panel.

13. Pick all the faces on the top side of the original geometry and press [Done] ( ). Faces are
merged.
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Now the upper face of the created primitive becomes a part of upper face of the original
geometry.

In the above steps, two methods [Align by Axis] and [Align by 2 Axes] of [Move Volume]
have been used.



In addition to these two methods, two other methods, [Match Points] and
[Align by Planes] are available in [Move Volume]. Followings are the
explanation of these four methods.

Please refer to "Appendix A, Move Volume" for details on the four
movement methods.

4.4.4. Extract Faces Surrounding Gaps and Create a Solid

If you prefer to fill the gap between volumes while maintaining the original shape as much as
possible, it is recommended to create a new volume manually instead of using [Create
Primitive] function which aims to fill complex gaps automatically.

Preparation

Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. In "Open"
dialog, select " Surrounding.drfx_sx " in <tutorial> folder.

1. Select "Gap" in [Main (Work)] panel > [category list] to check the gap.
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Navigation panel will display icons for filling gaps and extracting faces around gaps.

2. Press [Extract Faces around Gaps] ( ) in Navigation panel to switch to Twin View display
and extract the faces surrounding the recognized gaps (*1).



(*1) Decide whether to extract the neighboring faces. ([Envelop Solid] >
[Options] > [Envelop (Gap)] page > "Faces around the gap only" or "Faces
around the gap + Neighboring faces" option.)

Left view shows the original geometry with the extracted faces (*2), and Right view shows
the extracted faces only.
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Following description explains how to extend extracted faces and how to remove
unnecessary faces to create new geometry which fills the gap.



(*2) Use [Show Extracted Faces in Left View] ( ) or [View] > [Twin View
(Envelop)] > [Show Extracted Faces in Left View] to show (overlay) / hide
the extracted faces in Left view.

When it is difficult to visually check the gaps in the original model on the
left view, it may be easier to visually check by hiding the extracted faces on
the left view.

Navigation panel will display icons for editing the extracted surrounding faces.

3. Press [Extend Face and Trim] ( ) from Navigation panel.
Pick the edges on the boundary of the face you want to extend in order, and then press
[Done] ( ). The picked edges are highlighted in blue.
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4. Next, pick the bottom large face as depicted below and press [Done] ( ).

5. Finally, click [Run] in [Option] panel to extend and trim the face at the specified position.

Faces are extended and trimmed at the specified position.

6. Press [Quit (Esc)] ( ), and then press [Cancel] from [Option] panel to exit [Extend Face and
Trim] command.

7. Select [Edit] > [Delete] from the menu or select [Delete] ( ) on the toolbar. Pick the
unnecessary face (area in blue) as shown below.
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8. Press [Done] ( ) to delete the picked face.

9. Select [View] > [Twin View (Envelop)] > [Edit in Twin View] or press [Edit in Twin View] (
) to exit Twin View.

10. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes.

4.4.5. Create Solid by Extrusion

Fill the gap of a geometry by extruding a face. By using this functionality, you might be able to
fill the gap better than [Create Primitive].
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Preparation

Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Select "
extrusion.drfx_sx " in <tutorial> folder.

First of all, remove the fillets associated with the plane you want to extrude.

1. Select "Fillet" from the category list in [Main (Work)] panel. [Check/Uncheck Fillet] (  ) will
appear.

2. Pick fillets around the gap in order as shown below. Then press [Done] ( ).

3. A confirmation dialog will appear. Enable "Apply to all places" and click [Yes].
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The fillets are recognized. Also, the areas recognized as fillet are highlighted on "3D View"
window.

4. Click [Remove All (Fillets)]( ) in Navigation panel to remove recognized fillets. Two fillets
are removed.

5. Select [Envelop Solid] > [Create Solid by Extrusion].

6. Select the lower face around the gap as depicted left below to specify the face to extrude.
Then select a point near the upper face to specify the direction of extrusion as depicted right
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below.

The gap is filled in by the extruded geometry.

7. Press [Quit (Esc)] ( ) to exit [Create Solid by Extrusion] command.

8. Select [Envelop Solid] > [Merge Volumes] > [Merge All] to create a single solid model by
merging volumes.

All volumes can be merged into one solid.


Please note that this step can be skipped by checking "Merge the extruded
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volume and the original volume" option displayed at the lower left of the
window during extrusion.

4.4.6. Create Solid between Selected Faces

Fill the gap between selected faces by creating new solid. The shape of new solid is defined as
the intersection of the solids which are extrusion of selected faces. This functionality might be
useful in case [Create Solid by Extrusion] creates a solid which includes unnecessary portion.

Preparation

Select [File] > [Open] from the menu or select [Open] ( ) on the toolbar. Open "
facegap.drfx_sx " in <tutorial> folder.

1. Select [Envelop Solid] > [Create Solid between Selected Faces].

2. Select "By offsetting selected face" in [Option] panel.
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3. Pick the first face on "3D View" window. To specify multiple faces, pick the faces
consecutively, and then press [Done] ( ).

4. Next, pick the second face and press [Done] ( ). The specified face is offset, and a new
solid is created to fill the gap between the two faces.



It is also possible to specify "curved surface" for the face.
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About [Create Solid between Selected Faces] Option

■ For "By Plane" in "How to define the direction"

After specifying the first and second faces or group of faces, pick the face that specifies
the direction you want to extrude towards. Extrusion is executed in the normal direction
of the specified face.

■ For "By axis connecting 2 points" in "How to define the direction"

After specifying the first and second faces or group of faces, pick one point on each face
or on a group of faces one at a time.

When you check "By axis connecting 2 points", the face is extruded to the direction of the
axis connecting selected 2 points.
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Appendix A: Move Volume
With [Envelop Solid] > [Move Volume] function, it is possible to align by [Align by Axis] or
[Match Points] when the volume to be moved is not tilted with respect to the base volume. Also,
if the volume is tilted, the method [Align by Planes] to rotate the volume and then [Match
Points] is effective. [Align by 2 Axes] is effective when a complex relative position exist between
the two volumes that cannot be perfectly aligned by either [Align by Axis] or [Align by Planes].

A.1. Move Volume (Match Points)
The volume will move to match the two specified points. The volume does not rotate.

■ Operation

1. Select the volume that you want to move.

2. Pick any point on the volume that you want to move. Then pick any point on the target
volume to align to.

A.2. Move Volume (Align by Axis)
Geometry moves to align the selected edge of itself to the edge of target geometry.

■ Operation

1. Select the volume you want to move.

2. Pick one of the straight lines on the volume to move. Then pick any straight line on the
target volume to align to.
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

If necessary, Moving Volume rotates around the axis which is defined
automatically based on the selected edges.

A.3. Move Volume (Align by Planes)
Volume moves to align selected planes. To align planes, Moving Volume parallel shifts and then
rotates.

■ Operation

1. Select the volume you want to move.

2. Pick one of the faces on the volume you want to move. Then pick one of the faces on the
target volume you want to align to.


With [Align by Planes], the edges of the specified faces are not aligned. After
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using [Align by Planes], use the function [Align by Axis] to match the edges.

A.4. Move Volume (Align by 2 Axes)
Geometry moves to align virtual faces of Moving Volume to that of Target Volume. Virtual faces
are defined based on Primary Axis and Secondary Axis you selected.

■ Operation

1. Select the volume you want to move.

2. Pick an edge that will be the Primary Axis for the volume you want to move. Then pick an
edge that will be the Primary Axis for the target volume.

3. Pick an edge that will be the Secondary Axis for the volume you want to move. Then pick an
edge that will be the Secondary Axis for the target volume.



For both Moving Volume and Target Volume, specify Primary and
Secondary Axes. Secondary Axis must be parallel to Primary Axis. (See
Primary Axis (red) and Secondary Axis (yellow) in the figure below)

With the same logic as [Move Volume (Align by Axis)], Moving Volume moves first to align
its Primary Axis to the Primary Axis of Target Volume.
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Afterward, Moving Volume rotates around Primary Axis so that the plane composed of
Primary Axis and Secondary Axis of each volume is located on the same plane.
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All rights reserved by Elysium or the original author of this material. The content may not
be edited, reproduced, distributed, transmitted, displayed, published, broadcast, sold or
lent without the prior permission of the author.
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